new users can't connect to FTP

For some reason I can only log into an FTP with the default user for the Virtual Server. Trying to connect with an additional user for that VS won’t work. Here’s the report from FileZilla (I’ve replaced the username and domain for security):

Response: 331 Password required for user.domain

Command: PASS *****

Response: 530 Login incorrect.

Error: Critical error

Error: Could not connect to server

Can anyone help explain why? I’m hoping this is a common report from other users.

Thank you.


Is the username you’re using for that additional user the correct one? By default, additional usernames use the format “user.domain”. You can see the actual username to use in Virtualmin by clicking “Edit Users”.


Hey. Thanks for the reply. I am using the user.domain format given by Virtualmin - still doesn’t work.

What errors show up in the logs when you try logging in? You’d want to take a look at /var/log/messages, as well as either /var/log/secure or /var/log/auth.log, depending on your distro.


I have the log file /var/log/auth.log. It said the following at the bottom (I’ve changed the domain + IP for security):

Apr 30 19:14:22 ip-10-229-59-220 proftpd: pam_unix(proftpd:session): session opened for user danny.domain by (uid=0)

Apr 30 19:14:22 ip-10-229-59-220 proftpd: pam_unix(proftpd:session): session closed for user danny.domain

I found the answer! You were on the road to helping me though. I’ll post the solution here for everyone who ever has the same problem…

I looked at the log for proftpd here: /var/log/proftpd/proftpd.log

It showed me an error saying “Invalid shell: ‘/bin/false’”. In Webmin under Servers > ProFTPD Server > Authentication, for the field “Only allow login by users with valid shell?” change this to “no”.

Apply changes to proftpd (restart) and it works!


Ah, it sounds like the user(s) may only setup for email.

You can tweak their shell so that they can log in by going into Edit Users, clicking the username, select “Other user permissions”, and then make sure that “Login permissions” is set to “Email and FTP”.


No, problem solved Eric. Check my reply just before yours. Thanks anyway.