New mailboxes already have "trash" folder - how to disable?

I don’t know since when there is this behavior, but it must have been introduced in one of the newest virtualmin releases i guess…
When creating a new email account, the .trash folder is created in the Maildir. This leads to problems cause of bug of roundcube, which checks for existing folders case insensitively, so does not create the .Trash folder and then refuses to delete messages cause there is no “.Trash” folder.
I don’t want that .trash folder to be there in new mailboxes. How can I disable this? Have found no such option anywhere :frowning:

ok, i fixed the bug on the roundcube side, meaning that it will now check case-sensitively for existing folders, so Trash will get created.
however, I still would like to avoid having that .trash folder on all new mailboxes.

I’d like to know why the trash folder is created as well. I use the autocreate plugin of dovecot to create the .Sent .Drafts .Junk and .Trash folder when the user first uses imap. I don’t like there to be a .trash folder already after creating a new mailbox.

Anybody any solution?

You guys may want to bring all that up by filing a request using the Support link above.


Hello Guys,

I found out what was causing the trouble>
It was caused because the next file: ‘/usr/libexec/webmin/virtual-server/’ created the .trash folder.
If you edit this file and search for .trash you can either remove this line or change it to .Trash for example


local @folders = ( “$md/.trash” );
local @folders;
guess it should work fine now…

there will be an option to disable that in the next virtualmin version, see :slight_smile: