New install - websites won't load (probably easy fix)

I am still learning Linux, so please forgive me if I miss something stupid.

I just did a fresh install of CentOS 6.2 and VirtualMin 3.99.gpl.
I had no issues with and VirtualMin seemed happy with everything (checks all go through fine).

My hostname for this domain is
I set my hostname as
I pointed’s DNS info at my regisrar to my hosts nameservers (I’m on a VPS and they gave me nameservers to use)
I created a virtual server for, uploaded some test files (index.htm and test.php) and I can’t load the site. It would seem to be a networking or Apache issue.

I searched and read numerous forums with similar problems and tried the suggestions there. I went to System Settings > Virtualmin Configuration > Networking settings and saw my Network interface is set to “venet0:0” which I understand may be virtualized, so I changed that to “venet0” but didn’t fix anything so I switched it back. I tried manually setting Default virtual server IP. I changed my Default IP address for DNS records to “Automatically detect…” (didn’t work), then to “Same as virtual server IP” but still nothing.

So then I checked the Apache Document root for the Virtual Server and it shows it as “/home/opoza/public_html” which is exactly where the .htm and .php files are.

I looked at various access and error logs and can’t find anything where I’m connecting (or failing to connect).

Anyone have any ideas on why my fresh install isn’t loading pages or how I can diagnose this problem further?

Any help would be appreciated!


The errors I get for your domain are DNS related. You may want to review your DNS settings and nameservers.

What I’d recommend is to go to, and enter your domain name. That’ll provide a DNS report, and show what errors are present.


Thank you andreychek! I believe that was my problem. I changed my nameservers from the ones my host gave me to ones I setup myself and it seems to be working now.