New Install locked all outside ports

Good morning everyone!
I have installed Virtualmin/Webmin on my CentOS 7 server successfully!

I can get to the control panel’s just fine within my private network and both work great…

But I can no longer ping my public IP address ##.##.##.## or open any ports on my server. I would like to temporary turn off all firewalls within Virtualmin and see if I will be allowed to ping my public ip address and get to the admin panels on both ports.

I was able to also setup a Virtual server successfully. This is my first install and my first time using this panel. wow, it is SUPER GREAT! and I am loving what I am seeing and able to do quickly as I learn this new system.

I am a ISP Hosting provider (1-man shop with zero budget) at this time and would like to setup and connect my WHMCS payment system to it. But I will ask about that after I see and test Virtualmin configurations. But for now, how do I setup and configure my server to allow access to panels via the world public networks. I will want to allow users to use their admin panels, etc.

This is all installed on my lab test server for now and not my production system. (Man am I happy I did not install on production server, cuz everyone would be locked out now)

Or is there a way to just open up the public IP address to the public users without disabling all firewalls… I even tried to switch firewalls too. but I am not a firewall expert, so I am not sure what I am looking at in the config files on server.

p.s. I choose to SHARE IP on public ip address in configuration.
also, I was able to get to server before the install just fine…

Thanks for step-by-step help!!!

oh wow. I did everything correctly to fix my own issue with firewall… I switched from the Centos firewall to the other one… I thought that would happen in real time, but it does not.

YOU HAVE TO REBOOT to take effect… man I feel awkward here and in left field.

My system is now up and online and I can get to the control panels just fine.

Thank you Edwin Carroll for your help. LOL

1 Like

What “CentOS firewall” do you mean? As I understand it, the default firewall in CentOS 7 and 8 is firewalld, which is what we configure and use. If you had something else, that’d be something configured differently than a standard CentOS installation.

I need to close this issue now… I fixed the issue by just changing firewalls within the Virtualmin Admin Panel.

Thanks Joe for giving me a heads up.
Have a great day. I got to somehow get this big huge tree off my house that fell on it yesterday during our twister/storm that hit here in York County, South Carolina. I never had a tree fall on my house before in 66 years… wow…Take care…

I gotta learn how to close this issue in this forum.

Comments can be marked as “Solution”, look in the ... menu under the comment. I’ve done that for this post.

I’m still not sure what other firewall would be the “CenOS firewall” if not firewalld. :wink:

Thanks Joe for your help in this forum!

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.