New Install - LEMP - PHP Can't connect to MySQL

Hey All,

I just installed VirtualMin and I’m having an issue connecting to MySQL from PHP. I can connect without issue from the CLI using the same credentials, yet when I try from a script like Wordpress it doesn’t see the instance at localhost. I have tried the uninstall/reinstall without any luck, same result. The only clue I have is that after the install VirtualMin say’s there’s no password set for admin, yet this is not the case. If I try to enter a new password at that point in the wizard it throws an error:

SQL update user set authentication_string = password(‘xxxyyyzzz1122233’) where user = ‘root’ and host = ‘localhost’ failed : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘(‘xxxxyyyzz1122233j’) where user = ‘root’ and host = ‘localhost’’ at line 1

I’ve verified that the php mysql package is installed, so I’m somewhat stumped.

Any ideas would be appreciated.