New Bootup Actions virtualmin-init module

Howdy all,

As mentioned in the previous post, there’s a new sheriff in town…er…rather, a new module in the Virtualmin repositories. It’s called Bootup Actions, and it optionally allows your Virtual Server owners to manage actions to be executed on bootup and shutdown. For example, it can be used to start the Mongrel processes in a Ruby on Rails deployment, which is what we’re doing with it. But, your users can use it for all sorts of nifty things. Bootup Actions are executed as the user that creates them, so they are generally safe, and it’s more polite than everyone having cronjobs that are always checking to see if things are up and running.

We’ve added this package as a dependency in all of the virtualmin-base packages–so an update should add this module automatically. Or you can grab it explicitly. The next version of the software updates module will also be aware of it (but the current one is not…egg? chicken? egg? chicken? Oops…But don’t panic! I’ll roll that package out shortly).

Anyway, as always, give it a try, holler if it starts fires.

Hi Joe, Where can we grab it explicitly? And where can I find the instructions of installing the plugin? Thanks in advance! – B

  1. log in to your virtualmin interface.
  2. on main screen (system information) under "system" there should be a link at the bottom to update packages and install additional packages…if not just go to https://yourserver:10000/security-updates/ and there should be a list of all available virtualmin packages…

Hope it helps…

@steve - Thanks for your help. I don’t seem to have that option, only the option to upgrade to a paid version, which I wouldn’t mind, but don’t have the loot to spare. The link receives an, “Error - File not found”, in my Virtualmin. Do you know of, or where I could find out a command line way of obtaining it(or the latest GPL version) and installing it?

My current setup:
Sun Solaris 11
Webmin version 1.340
Virtualmin version 3.40.gpl

Another setup that I have that has the module:
Operating system Sun Solaris 11
Webmin version 1.380
Virtualmin version 3.48.gpl (GPL)

@steve - While I was writing this Linda pointed me out to a walkthrough of how to get this done( Thanks again! – B

No luck getting the Bootup Actions module. After upgrading the webmin, the virtualmin remained the same and I couldn’t find the “Bootup Actions” module in the webmin modules section of webmin. Any advice on how to obtain this module would be appreciated. Thanks!

i am not totally sure, but i believe that virtualmin plugins only work in the paid version, as with a lot of other awesome features not in GPL.

@steve - Thanks for the response. I got an answer to my question over here on the Joyent forums:

So, I guess I’m supposed to ask Joe or Jamie for it. I tried exporting from the server I have it on and installing it as a module on the one that doesn’t have, which partially worked, except that when I installed it the bootup action module showed up and let me specify the SMF, but didn’t have the cool templates for starting up Mongrel Clusters or Lighttpd when you do sudo apachectl.

And its always been in our GPL repositories for CentOS/RHEL 5 and Debian 4 (though I need to update it to the latest version).