Network got reset after first reboot

Hello guys!
I downloaded and installed virtualmin and set everything up. After the first reboot the entire server got fucked. The server is no longer accessible via the internet.

I didn’t actually run any other commands that could lead to such a result.

Does anyone have any idea what could have been the trigger and how to fix the problem?

Best regards :grinning:

Hopefully you have kvm or other access to the machine. Something similar happened to me frequently a while ago on CentOS 7 where my virtual interfaces (additional ip’s) were losing their netmask and were partially inaccessible as a result. I never noticed as my primary ip was fine, where it manifest itself was in DNS resolution to a remote ssh server for virtualmin/webmin backups. So I would check that in your etc/sysconfig/network-scripts or where-ever your network setup is saved. It may be a simple fix.

Thank you for your feedback. :grin:

I have now reinstalled the server because I thought I might have done something wrong.
Ubuntu 18.04.3 LTS is freshly installed on the server and after the first reboot I have exactly the same problem.

How can it be that this occurs in a fresh installation?

Does anyone know how to fix this?

Try going to Networking/Network Configuration and hit apply first.

Did you do any network specific changes using netplan or anything else network related?

Can you post your network configuration files? (I assume you’re using netplan, support for which is still pretty new…those files are in /etc/netplan)

@Ilia Done that but the server still does not comes back online after the reboot. I checked the settings and set up a test page. Everything worked as expected, only after a reboot does the server stays offline.

@Joe Before installation of Virtualmin: after installation:

huh…the only difference I see is the on-link: true bit. I’m not sure I understand it enough to know what’s going on there, but does the new network config start working if you add that back to the routes: section?

Oh, also, please copy/paste stuff like this as plain text into the forum (within reason; don’t post a hundred lines of logs or whatever, but config files are useful). Screenshots make it hard to do things with it (like testing locally), as we’d have to type it all in manually and would likely make mistakes. You can wrap that kind of thing in a pair of ```, e.g.

some plain fixed-width text

lol i just replaced the virtualmin config with the original config and now it works again.

My config:

Apparently, addresses can also accept an array. @Jamie Did you consider it?

Is the cause that the list of addresses like [‘a’, ‘b’, ‘c’] is not treated the same as a , b , c on separate lines?
It will probably be due to the non-existent space.

That we can easily fix, but are those spaces really required?

Still not fixed.

Just use new lines like you can see in the pastebin note. Easy as that :slight_smile: