Network dies when saving DNS settings


Fresh Debian 4.0 x64 system, and fresh install of Virtualmin 3.57.
Install went fine, and upon login I got this message:

Virtualmin's configuration has not been checked since it was last updated. Click the button below to verify it now.

So I did this, then this came up

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add to the list of DNS servers, or turn off the BIND feature on the module config page.

So I followed instructions, and added to the list.
Then clicked "save".
So far so good.
Then I click "Apply Configuration" and nothing happens. The browser waits, as the network goes down.

So on serial console I can recover normal operation:

hannibal:~# ifdown eth0 **** /sbin/dhcpcd-bin: not running hannibal:~# ifup eth0 e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex dhcpcd.exe: interface eth0 has been configured with new IP=***.***.***.***

And everything is reachable again, but Virtualmin forgot the DNS settings and still does complain that the system is not ready for it.

What can I do?

I ran into similar issues where the network hangs after I clicked apply configuration. The problem was I forgot to set my virtualmin server to use static IP after I was done installing my Debian etch box. I easily resolved this by using Webmin’s network configuration tool.

i tried setting the interface statically, but unfortunatelly this doesnt fix the problem for me :frowning:

Then I click "Apply Configuration" and nothing happens. The browser waits, as the network goes down.

Skip this step.

The "Apply Configuration" runs whatever the network restart command on your system is…if your configuration is broken, it will take you network down.

When changing DNS client or any of those settings, you do not need to "Apply Configuration". The changes are already made when you click "Save" on the page.

Thanks, it worked. Although I wonder what might be wrong with my configuration, since I didn’t mess with it…