Need to publish contents in subdirectories, getting error "Internal Server Error"

Switching over from Plesk and liking what I see so far :slight_smile:

I’ve got my website up and running, however I am trying to publish another site from a subdirectory of my original site.


In Virtualmin under my “virutual server options” I have added under “per directory options” an additional entry to reflect the directory where my second site is: “/home/mysite/public_html/second_website”

When I visit I receive “Internal Server Error” (Error 500).
If I visit I properly get redirected to’s 404 page.

The error log for was over 1GB (set the server up a few weeks ago for testing) so i deleted the log and created a new identical file name and it remains at 0 when trying to access the website.

I’m sure this is just a setting somewhere.

The is a joomla website and the is a magento site if that helps anything.

Thanking you in advance,



Top-level server =>

Sub-server =>

If you’re trying to setup two unique domains, it’s best to have them setup as “Top-level” template, and if you’re trying to setup a subdomain for the second domain, it is best to use “Sub-server” template.

Without knowing what you mean by “second_website”, it co9uld be assumed that this is:

A) two unique domains

B) a single domain, and subdomain

C) a single domain, with a sub-directory

Please clarify so we can be of greater assistance. Further, you can check the error logs at: /var/logs/virtualmin/domain_error_log for any hint as to why you’re getting the nasty 500 error.

Post or email me for further assistance.

Best Regards, Peter Knowles TPN Solutions

P: 604-782-9342

Thanks for the reply!

Actually they are the same domain, I’m trying to have the magento site working within a subdirectory of my joomla site. I have this working fine in plesk.

So essentially my joomla is in:


And magento is in:


Is there anything I’m overlooking?


EDIT: Rechecked the error log and it now has data in it from this morning, this indicated “.htaccess: Option FollowSymLinks not allowed here”

I’ve removed the .htaccess file and now my magento site is working.

So now I have 2 quick questions:

  1. What line should I add to the .htaccess to allow “FollowSymLinks” as I do not want to run my site long term without it?

  2. Why would it take so long for the errors to show up in the log?




If it works with without using “FollowSymlinks”, then there’s no need to add anything else… but if you run into any problems, you could always use SymLinksIfOwnerMatch in it’s place.

It’s surprising that it took the logs so long to update though, they should typically be updated immediately.