Need PHP 56 - SCL PHP 56 no longer available?

I am setting up a new server with Centos 7.7 and would like to have multiple PHP versions in addition to to 7.2, at least 5.6. All the instructions say to install the SCL versions via yum, but those are no longer available through yum, though the rpms are via direct download. Should I just install the rpms and will that work similarly? Thanks

I think 7 has them pre-install already. If you want 7.4, you could install from VM Depository…

Thanks. Centos 7.7 has PHP 5.6 already installed? I don’t care about PHP 7 at this point as everything that’s on this server is legacy and doesn’t run on the public internet. I do want Centos 7.7 though for other things.

As it turns out installing SCL PHP56 via rpm is difficult with all the dependencies, some of which aren’t available through SCL, so not sure how to handle this. I was able to install php56 through the Remi repo, but it breaks when running some of the php scripts I have, so I am not sure if it installing in parallel with php 7.2, which is what I want. Just can’t seem to get 5.6 working properly, but I know the SCL method works fine on my old server.

I made the mistake of installing 5.6 onto C7 and my server crashed. C7 has 5.6 pre-installed.

ah ok, but weird. I didn’t see 5.6 installed on mine(centos 7.7), just 5.4(default) and 7.2 I believe, though I am not sure if 7.2 was added by Virtualmin install. I managed to create a repo from the PHP56 located in the SCL Vault and installed it that way so it is working now.


You could install PHP 5.6 with REMI safe repos on CentOS 7, as easy as that:

yum -y install && yum clean all
yum -y install php56-php-{cli,pdo,fpm,zip,gd,xml,mysqlnd}
1 Like

not sure if this will help … similar to some of the REMI repos, Webtatic also has php5.6 available … we have used it for awhile as a replacement … aka … default/primary php engine …

… at least I think 56 is still there … as with a few other repos, the actual repo/package name is unique

yum list php56w
Installed Packages
php56w.x86_64           5.6.40-1.w6            @webtatic

but as the default or only package, you get

php -v
PHP 5.6.40 (cli) (built: Jan 12 2019 09:19:57)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies


I tried that previously, but for some reason when I would run my old scripts it would return undefined function errors on functions I know were supported by php 5.6, albeit deprecated ones. E.g. mysql_connect. These are old scripts that run internally and not worth converting - they were poorly written too. Anyway, not sure why those errors were happening but after I installed the SCL ones and removed the REMI ones everything worked. It was weird. My guess is PHP 7 was running the scripts somehow despite me explicitly running php56 on them.

Thanks again all for the help.

Never say third party repos are “easy”, Ilia! They often cause trouble, even the good ones.

I agree, that it might not always be smooth but the good (easy) part, is that it doesn’t replace any existing packages, and can be flawlessly removed from the system as simple as that:

yum history undo last

… besides, I tested it before recommending it.

… My guess is PHP 7 was running the scripts somehow despite me explicitly running php56 on them.

PHP 5.6 is EOL, it’s explicitly stated upon installation -


  WARNING : PHP 5.6 have reached its "End of Life" in
  January 2019. Even, if this package includes some of
  the important security fix, backported from 7.2, the
  UPGRADE to a maintained version is very strongly RECOMMENDED.


Yeah I know it was EOLed. As I stated, this was for some old scripts that were poorly written that I just want to keep running. Fixing them is pointless as it would take several days and the scripts run internally, so despite the security concerns, there are none in my case since they are inaccessible to the outside world. For whatever reason the REMI PHP56 didn’t even recognize a still working function as of PHP 5.6. Removed it and got the regular SCL one installed and it works now, whatever the reason may be.

Another issue is I have serious spine issues, just had neck surgery and can’t spend more than about an hour a day in front of a computer. I am being forced to migrate to a new server, otherwise I wouldn’t be doing any of this.

Thanks for your help. Fortunately I figured out how to get it all working. New server will be set up soon, fully functional.

Curious, is that WARNING message indicating the security fixes incorporated into PHP 7 were also incorporated into REMI’s 5.6, explaining why I had issues with their PHP 5.6? That would explain my issue.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.