Need help with SMTP configuration, i have an issue

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.021
Virtualmin version 7.5
hello, i use roundcube as my website email everything works normal (i can send emails and receive them), BUT when someone in my website forget about there password and they click on “lost your password” my roundcube should send them email (that have the url so they can set anew password) but my roundcube dont send anything!!!i think its related to SMTP configuration… can anyone help???
1 Like

I don’t have the “lost your password” option, not sure how roundcube can change password either.

I said in my website, every website have “lost your your password” in “login” the roundcube aint sending the url so the user can send thier website…, Sorry my english aint perfect

Virtualmin or webmin has the only ability to reset password (as far as know.) how did you create this “lost your password” option as I don’t know it.

If its not roundcube section. What password reset are we talking out? Wordpress?
Can you send screenshot this the “lost your password” as roundcube would not handle it. Roundcube sending emails is only for roundcube webmail.

my roundcube after failed login, no option.

There’s a plugin for password recovery/reset for Roundcube.

But, we aren’t the Roundcube developers or the developers of that plugin, and I don’t use Roundcube, so I don’t know how any of it works.

OP, you need to look in the mail.log (or the journal for the postfix unit) to see what’s happening. We can’t possibly guess with no information.

No you mean your mail server (postfix) sends an email not roundcube (this is a client) . I would be checking the software (wordpress or whatever it is) for errors as well as checking the mail server logs

stefan1959 and Joe its as jimr1 said, sorry… im try to fix it using wordpress SMTP plugin, but i need SMTP Host and Port plus usernampe and pass… anyone know where i can find them in webmin??

You set the domain up so you should know the username and password. The hostname will be the domain name prefixed with ‘mail.’ so it would look like ‘’ … your port can vary on the services you use for email but try port 25

yes im using port 25, but its not working…, i even test it on SMTP Test Tool and its not working the error is “ERROR: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond”… is there anything i can do? maybe its a SMTP configuration issue?! plz help

I can’t figure out what you’re trying to do or what you’ve tried. I don’t see any logs, though, so everyone is still just guessing.

I also don’t understand what you think you’re testing with SMTP Test Tool? I don’t see how it could test local clients sending mail through the local mail server, which is what I thought was the problem you are trying to solve.

1 Like

sorry xD, look at the pic u wil understand, im trying to use this pluging and i need my SMTP for it…but its not working for some reason…

I guess send a message from wordpress which is failing

Is this on the same sever as VM? If so I’ve never used a smtp plugin as it should work without one, normally you only need them to connect to a external server.
Most forms work fine without the plugin.

1 Like

If WordPress is on the Virtualmin server, and if the Virtualmin server is able to send mail (i.e. you are hosted by a provide that allows port 25 outgoing traffic, which not all of them do), you should send via localhost and you don’t need authentication.

But, I continue to beg you to give us logs. Everybody is guessing without the danged mail log (or journalctl -fu postfix if you don’t have a mail.log).

I’m gonna stop trying to help, if you won’t provide the information we need to help.

Yes, as i said before everything works normally but i doesnt send the “lost your pass word” url when a user from my website tries to reset the password…, Thats why im tried to use SMTP pluging…

@Joe how to get mail logs??


Smtp settings can be found here.

edited: wrong mail.logs…

stefan1959 thats the smtp sittings? u think they are right?

and thats the error name “error SMTP code 101” can anyone help?