Need Help Please - After disabling Apache SSL - Can't enable it anymore

Operating system CentOS Linux 7.9.2009
Webmin version 1.991
Usermin version 1.840
Virtualmin version 6.17
Authentic theme version 19.91.2
Kernel and CPU Linux 3.10.0-1160.62.1.el7.x86_64 on x86_64
Processor information Intel(R) Xeon(R) CPU E5-2630 v4 @ 2.20GHz, 6 cores
CPU load averages 0.22 (1 min) 0.15 (5 mins) 0.20 (15 mins)

I am not a coder so basically just go with doing whatever I can from the menu on Virtualmin.
I have a website where SSL did not automatically update and tried frustratingly to get it updated from LetsEncrypt and it kept failing.

Finally after a few days someone online suggested I go to Edit Server on Virtualmin and disable the Apache SSL (he said that would remove all SSL stuff from the server and go back to Edit Server and Enable the Apache SSL then go and get a fresh new SSL certificate from Lets Encrypt.

Sounded feasible to me so I edited the server and disabled the Apache SSL and saved it then went back to edit the server and enable SSL – I can’t enable it – it keeps saying:

Can’t edit server for apache SSL keeps saying:

Changing IP address of virtual website ..
.. no Apache virtual host found!
Adding new SSL virtual website ..
.. could not find non-SSL virtual website to copy directives from!

Now I know I shouldn’t have listened and done this but … too late now and I really don’t feel comfortable with the chap advising me. Really would appreciate some help please.

How do I enable SSL again & finally update the certificates that are already in the home>ssl?

Yup, you should be careful about advise that you follow on a production system. And keep backups if things go wrong.

Well, it seems that your series of operations have caused the Apache config files to somehow omit the host / related config info of the domain or virtual server. This should not have happened even if the sequence of operations that you have outlined have been performed via Virtualmin. If, however, you have followed advice and edited config files manually, then you alone would know what you have done and Apache therefore is unable to start with the config files that are there at the moment.

If you wish to do so (more advice coming up!) you could disable the virtual server via Virtualmin and then try to start Apache. Let us know if that works. The best case scenario here is that all your other websites will start working, except this one. In that eventuality, we could further advice you on how to get that one working too.

Simply disable Apache website as well. Save it and then re-enable both Apache website and Apache SSL website in Edit Virtual Server page.

tried this but it didn’t work for me
so i’ve now just deleted the virtualmin servser of that website and restored it all from a backup i had
This is a virtualserver backup and so it’s showing Apache SSL enabled
now I need to manually update the old SSL certificates… PHEW!..

so need some help with that
I am a newbie and so having difficulty with this
would prefer to do this via the menu and hopefully no coding etc… if possible
Please help… Thanks

This would be easier to request a new SSL certificate using virtual-server.name - Server Configuration ⇾ SSL Certificate / Let’s Encrypt page.

1 Like

Thanks Ilia - that worked, I’m surprised as that was the very first thing I did before doing anything and 3 times it failed one day and 3 times again the following day b4 i started doing the disabling ssl etc…
and it kept failing… Grrrr… anyways - Thanks for all the help - It’s worked out fine :+1::+1:Regards
ASM

1 Like