Need help on Webmin / Usermin mail ....

I use to install Vistualmin / Webmin but my webscript looks fine working in Webmin (root) so I don’t create new server in Virtualmin and use Webmin (root) for my webscript under /var/www/html, but now the problem arise when I want 2/3 incoming outgoing mailbox for my webscript.

M using CenOS 6 32bit, suppose my ip is 111.222.333.444 and my domain in

I used following list of commands form ‘,centos_5_install/’ for install and update Webmin in my VPS.

yum update yum install perl yum install nano nano /etc/hostname enter '' in the new file 'hostname' make a backup of file 'hosts' 'cp /etc/hosts /etc/hostsbackup' nano /etc/hosts enter '111.222.333.444 myhost'
    before " localhost.localdomain localhost localhost4.localdomain4 localhost4 and ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 "
hostname --fqdn cat /etc/hostname cat /etc/hosts hostname -d hostname -s hostname -f uname -a wget /bin/sh yum update

After that enter into Virtualmin by ‘
Configure ‘Post-Installation Wizard’ as follows . . . . . .

  • Preload Virtualmin libraries? = No
  • Run email domain lookup server? = No
  • Run ClamAV server scanner? = No
  • Run SpamAssassin server filter? = No
  • Run MySQL database server? = Yes
  • Run PostgreSQL database server? = No
  • MySQL configuration size = 'Medium system (512M) with regular MySQL use'
  • CHECK 'Skip check for resolvability'
  • Password storage mode = 'Only store hashed passwords'

    I use maximum mail related option “NO” in ‘Post-Installation Wizard’ because m not using heavy mail system, only need 3 following mail ids to send and received e-mails by Usermin.

    Under ‘/var/www/html’ form ‘Webmin -> Others -> File Manager’ I upload my files and installed the webscript but can’t make this 3 mail account and use it with my script .

    I just want to know, do I miss anything or do I skip any step(s) which may setup my mail box with mail account(s). Please guide me, what I have to do next to setup this 3 mail id account(s) without making any more extra users or groups ???
  • Howdy,

    Well, Virtualmin uses /home for websites and email, not /var/www.

    You may have a difficult time trying to get it to work using an alternate directory, as it isn’t designed to work that way.

    That said – what problem are you having specifically? You mentioned that you are experiencing a problem setting up email, but I don’t see what problem it is that you’re having.

    Let us know what problem you’re having, and what errors, if any, show up in /var/log/maillog when the issue occurs.


    Thanks for the reply -Eric

    I understand what U mean but when I use or or, it redirect me to the default apache page and when I upload my webscript into ‘/var/www/html’ and install it, it worked with my domain name without any nameservers configuration inside Virtualmin -> new user -> DNS record. So I thought may be using ‘/var/www/html’ under root is good.

    Lots of thanks for the guideline but please help me a little more …

    As I told before, I used ‘,centos_5_install/’ instruction for install and update Virtualmin / Webmin in CentOS 6 32bit. In this page, some where it instruct to do

    nano /etc/hostname

    nano /etc/hosts
    111.222.333.444 myhost

    ‘hostname’ is a new file under ‘/etc/’ but ‘hosts’ already contain following lines localhost.localdomain localhost localhost4.localdomain4 localhost4

    Auto-generated hostname. Please do not remove this comment.

    111.222.333.444 myhost
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

    I changed it with into

    Auto-generated hostname. Please do not remove this comment.

    111.222.333.444 myhost localhost.localdomain localhost localhost4.localdomain4 localhost4

    M I did something wrong by changing the line pattern inside the file ‘hosts’?
    Without setup a new server user under Virtualmin and without configure nameservers under new server user DNS record - how can I get my website directly form root ‘/var/www/html’
    Can U please guide me or help me or redirect me into a simple and proper process of Virtualmin full installation inside CentOS 6 32bit including 3 email id accounts construction by SSH and https://ip:10000 and https://ip:20000 I already waste 22 days by reading and doing trial and error method but everytime I faced some problem like domain name configure error, outgoing email error or Webmin stop. I would be highly oblige if U kindly help me … lots of THANKS in advance.

    Need help for making mail account working properly … please help

    M using CenOS 6 32bit, suppose my ip is ‘111.222.333.444’, my domain in ‘’ and my host name is ‘

    Login using root id and pw in
    use Virtualmin -> Edit Users -> Add a user to this server
    use ‘no-reply’ as mail id, therefore email will be ‘’
    fill ‘Real name’ and ‘Password’ and hit ‘Creat’

    but after create mail id ‘’ m facing 2 problems

    1= when I try to enter mail account by
    Virtualmin -> Edit Users -> CLICK ‘no-reply’ -> Login to Usermin
    I can enter mail box but when I try to enter form
    I get ‘Login failed. Please try again.’ and I used
    but result is same ‘Login failed. Please try again.’

    2= When I send any mail form any external mail id to ‘’
    I can easily receive the mail but when I try to send mail form ‘’
    to any external id, I can not receive the mail(s) after a 24 or 48 hrs.

    How do I configure my mail account so that I can open my mail from Usermin or
    (don’t know which one to use or using which one is correct)
    How do I can able to send mail form my mail ids


    Can someone please help …

    Don’t be so impatient. Also, putting entire paragraphs in bold or capitals doesn’t help.

    1. What credentials are you using? Virtualmin will show you the correct username in the “Edit User” screen. It depends on various bits in your Virtualmin config.

    2. Check the mail log in /var/log at the moment of send attempt, if the mail was delivered successfully, and if not, what happened.

    Do U think, waiting near about long 2 days (from 2014-02-07 15:45 to 2014-02-09 01:49) is a sign of “impatient”. . . then m SORRY

    And I use bold or capitals for problems, what I did, what r the tropics I need help and what r the mistake /cause I need to rectify, - describe then separately form one another not for design the paragraph or nor for help me; I did all to make as much as easy for the reader to clear what I mean to say.

    1. I don’t understand what U mean to say by ‘Virtualmin will show you the correct username in the “Edit User” screen’ because I don’t say Virtualmin will not show me the correct username in the “Edit User” screen. Frankly speaking, it’s not clear for me what U mean in “What credentials … your Virtualmin config.” because m not so good at Virtualmin / Webmin, so I request for help, I surrendered.

    M using CentOS Linux 6.5 32bit, Virtualmin v4.04.gpl, Webmin 1.675.

    I just mean to say, I create a mail account ‘no-reply’ as per “” but I can open it from Virtualmin / Webmin (https://hostname:10000) Edit Users -> CLICK ‘no-reply’ -> Login to Usermin but can not open it form Usermin, showing ‘Login failed. Please try again’. I already try it by changing password form inside the Virtualmin but same as it is when I try with Usermin. and m receiving mail, incoming mail are fine but can’t send mail (after sending mail from compose section, it display “Sending mail to receiver mail id … done.” but mail can’t reach to receiver mail box, to whom I send mail)

    1. As per your define path, I get mail log file, contain lots of information and error massages, so fur I understand I get the following massage at the time of sending a mail to form "Feb 8 18:14:34 hostgoutam postfix/smtp[30892]: connect to[2a00:1450:400c:c00::1a]:25: Connection timed out. Feb 8 18:14:34 hostgoutam postfix/smtp[30892]: 81DAEC6BC62:, relay=none, delay=150, delays=0.09/0.03/150/0, dsn=4.4.1, status=deferred (connect to[2a00:1450:400c:c00::1a]:25: Connection timed out)

    M really appreciate your works and guidelines but m facing lots of trouble form the beginning as m not so good at Virtualmin, solved most of the problems by the help of U guys and form internet forums but m working on this mail problem for long times and at last, after waiting 2 days (from 2014-02-07 15:45) I try with second request to forum. Sorry if I did something wrong and please help me …

    Well you posted your “Can someone please help” just one hour after your previous message, hence my remark. Note that we’re giving help here for free in our spare time, also there’s timezones, so people aren’t always around to reply right away.

    1. On the “Edit User” screen (click “Edit Users”, then the user you want to look at), Virtualmin shows you the “IMAP / POP3 / FTP Login”. That’s the username you need to use in Usermin. (It can be, but does not have to be, different from the email address. You can configure in Virtualmin what format for usernames it’s going to use – like adding the full or partial domain name, separated with @ or . or something.) I suppose when you get the login error, you’re just using the wrong username or password.

    2. Your log shows that your server could not connect to Google’s email server. Since it’s trying to use IPv6 addresses, it might be related to that. Does your server also have an IPv4 address? If so, you might want to disable IPv6 in Postfix by adding the line

    inet_protocols = ipv4

    to the file /etc/postfix/ and restarting Postfix.

    M extremely sorry for the misunderstanding and really I mean that m appreciate your help for lifetime

    Roger, don’t worry. :slight_smile: Let us know if you’re making progress.

    I tried ‘inet_protocols = ipv4’ form the file ‘/etc/postfix/’.

    1- When tried ‘inet_protocols = ipv4’
    result show - “Sending mail to Goutam Chakraborty … done”
    but cause the same error and mail not send.

    2- When tried ‘inet_protocols = IPv4’
    result show - “Sending mail to Goutam Chakraborty …”
    but cause the error “Feb 8 21:14:39 hostgoutam postfix/pickup[4649]: fatal: unknown inet_protocols value “IPv4” in “IPv4”. Feb 8 21:14:40 hostgoutam postfix/master[6498]: warning: process /usr/libexec/postfix/qmgr pid 4650 exit status 1” and mail not send.

    3- When tried ‘inet_protocols = 111.222.333.444’
    result show - “Sending mail to Goutam Chakraborty …”
    but cause the same error "Feb 9 12:52:34 hostgoutam postfix/sendmail[2076]: fatal: unknown inet_protocols value ‘111.222.333.444’ in ‘111.222.333.444’ " and mail not send.

    Please help and guide what I can do now … ? ? ?

    N.B.- restarting Postfix failed when try with ssh ‘/etc/init.d/postfix restart’

    The setting is, as I wrote, “inet_protocols = ipv4”. No upper case, and not an IP address. Please post the full log excerpt when you try to send a mail with that setting active. It can’t be the exact same error as before, since before your Postfix was trying to use IPv6 addresses. Don’t forget to restart Postfix after making config changes.

    How do I restart Postfix ?? - by using ‘/etc/init.d/postfix restart’ form SSH (PuTTY).
    Or do Virtualmin have any GUI process of restart like restart
    APACHE SERVER form ’ Webmin -> Servers -> Apache Webserver ’

    Yes, the init.d command should work. Not sure for CentOS, I’m using Ubuntu. And yes, Webmin also has a Postfix module with a start/stop button.

    Yes, I did all as U said, SIR

    First change ’ inet_protocols = ipv4 ’ in the file ’ /etc/postfix/ ’
    Then restart Postfix by ’ /etc/init.d/postfix restart ’
    by SSH (PuTTY) as ‘root’ and it show OK (in green)
    Then collect the 1st mail log form ‘/var/log’
    Then try to send mail which display the following line
    " Sending mail to Goutam Chakraborty
    … done. "
    Then collect the 2nd mail log form ‘/var/log’
    And the different of 1st and 2nd mail log file is given below

    Feb 9 13:58:01 myhost postfix/pickup[4347]: F36C0C6BCEA: uid=501 from=
    Feb 9 13:58:02 myhost postfix/cleanup[4388]: F36C0C6BCEA:
    Feb 9 13:58:02 myhost postfix/qmgr[4348]: F36C0C6BCEA:, size=1145, nrcpt=1 (queue active)
    Feb 9 13:58:02 myhost postfix/error[4499]: F36C0C6BCEA:, relay=none, delay=0.16, delays=0.13/0/0/0.03, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]:25: Connection timed out)
    Feb 9 13:58:09 myhost postfix/smtpd[4546]: connect from localhost.localdomain[]
    Feb 9 13:58:09 myhost postfix/smtpd[4546]: 71BAAC6BCE4: client=localhost.localdomain[]
    Feb 9 13:58:09 myhost postfix/cleanup[4388]: 71BAAC6BCE4:
    Feb 9 13:58:09 myhost postfix/qmgr[4348]: 71BAAC6BCE4:, size=993, nrcpt=1 (queue active)
    Feb 9 13:58:09 myhost postfix/smtpd[4546]: disconnect from localhost.localdomain[]
    Feb 9 13:58:09 myhost postfix/error[4507]: 71BAAC6BCE4:, relay=none, delay=0.05, delays=0.05/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]:25: Connection timed out)

    Okay, the connection from your server to Google also timed out on IPv4:

    Feb  9 13:58:09 myhost postfix/error[4507]: 71BAAC6BCE4: to=<>, relay=none, delay=0.05, delays=0.05/0/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to[]:25: Connection timed out)

    Try connecting to that host via telnet and see if you can ping it or traceroute to it:

    ping mtr telnet 25

    You need to check if port 25 is blocked generally outgoing by a local firewall, by your hoster or something else. Maybe Google is blocking your IP for some reason. Difficult to say, can have any number of reasons.

    For further analysis, since this is getting somewhat time-intensive to debug via forum, I can offer to communicate via instant messenger and to log on to your system myself and try to fix things. I can’t promise though that I find a solution, and if it takes longer than about 30 minutes, I’ll need to charge a moderate fee (need to make a living and can only devote so much time to free help per person :slight_smile: ).

    My port 25 is not blocked by a local firewall because,
    when I try “telnet 25” by SSH root, it return

    Trying 111.222.333.444…
    Connected to
    Escape character is ‘^]’.
    220 ESMTP Postfix

    Not look like google blocking my IP because
    same thing happen with other mail server . . . . . also,

    when try to send mail to yahoo mail, it return …

    Feb 9 17:41:45 hostgoutam postfix/smtp[11292]: F20E1C6BDC9:, relay=none, delay=62, delays=1.1/0.43/60/0, dsn=4.4.1, status=deferred (connect to[]:25: Connection timed out)

    when try to send mail to gmail, it return …

    Feb 9 17:44:34 hostgoutam postfix/smtp[11292]: 3E3E8C6BDCC:, relay=none, delay=150, delays=0.06/0.02/150/0, dsn=4.4.1, status=deferred (connect to[]:25: Connection timed out)

    Is there any way that I can reset or reconfigure my total Postfix setting ?

    When you can telnet to port 25 of a server, Postfix should be able to connect to it too. I see no reason why Postfix should time out trying to do so.

    What server did you try in your telnet test? Using placeholders is not helpful when we’re trying to debug stuff. :slight_smile: Try telnet to port 25 of the exact IP that Postfix fails to connect to please.

    May be U r right …
    When I try telnet with yahoo mail by “telnet 25” I get -

    [root@myhost ~]# telnet 25
    telnet: connect to address Connection timed out
    telnet: connect to address Connection timed out

    When I try telnet with gmail by “telnet 25” I get -

    [root@myhost ~]# telnet 25
    telnet: connect to address Connection timed out
    Trying 2607:f8b0:4002:c07::1a…
    telnet: connect to address 2607:f8b0:4002:c07::1a: Connection timed out

    If my port 25 is block, how can I confirmly check it (means by which ssh command) ??
    How and form where can I open my port 25 form Virtualmin / webmin ??

    Please help …

    Please execute ALL the commands I posted in my previous post. I asked you to do ping and mtr too for a reason.

    ping mtr telnet 25

    (You already did telnet apparently. And you might need to install a package for mtr.)

    And please answer all questions that I post, otherwise it’s getting really stressful to try and help you. Namely, which server did you telnet to port 25 to previously, when it worked? Giving placeholder IPs is not helpful when trying to debug stuff.