Need Help! Can't access to virtualmin.

Dear friends!

I have problem to access to virtualmin on a VPS. Apache also does not start. Moreover, I can not access to the server via SSH. Though, I have console access. Webmin is running but is not accessible.

When I try to start httpd, it gives me the below error:

Cannot assign requested address: make_sock: could not bind to address serveripaddress:80
no listenin sockets available, shutting down
unable to open logs

I have below directives in httpd.conf file:

ServerName serveripaddress:80
Listen serveripaddress:80

I have google for the error but could not solve the problem.

Any idea about how to solve the problem is highly appreciated!

Best Regards.

That’s multiple issues, each with its own possible reasons. :slight_smile:

The Apache error usually means that a process (of Apache) is still running. You can do this to check that and restart Apache:

netstat -tpln | grep :80 service apache2 restart

What exactly happens when you try to access SSH or Webmin? The netstat command can tell you if those services are running: netstat -tpln

Dear Locutus,

Thanks for your reply.

I tried your netstat command and no line came up. No other program running on 80 port. :frowning:


Do you still receive that same error now when trying to start Apache?


Hi, Eric.

I still receive the same error. I tried changing the above-mentioned directives to *:80 and this time it says could not bind to address serveripaddress:9091 but I don’t have any 9091 port in my httpd.conf. Is there anywhere else that apache sets port for itself?

As virtualmin and ssh are also unaccessable, it takes hours to work on console. Sometimes it gets stuck.

Which distribution are you using? Are you on a OpenVZ based VPS?

What did you do exactly before these issues occurred? It’s unusual that you get problems like this with Apache, SSH AND Webmin at the same time. Maybe some hardware problem or resource limit.

Try to restart SSH and Webmin:

service ssh restart service webmin restart

See if they are listening:

netstat -tpln | grep :22 netstat -tpln | grep :10000

See if there’s a port 9091 mentioned anywhere in your Apache files. It should be – Apache wouldn’t try to listen on that port otherwise:

grep -r ":9091" /etc/apache2/*

Dear Locutus!

Thank you very much for your help!

The VPS is on digital ocean and the distribution is centos 6. The VPS has been running for a few months but I could not access to Virtualmin. So I decided to restart to be able to access Virtualmin.Then everything was gone.

I found where it was bind to 9091. The ssl.conf had it inside. Now I have changed Listen directive to *:80 and apache has started. But the site on the VPS doesn’t open.

I have restarted ssh and webmin and they are not accessible too. I had disabled CSF but have stopped it already. iptables -L command gives error FATAL: Could not load /lib/modules/2.6.32-358.6.2.el6.x86_64/modules.dep I have just tried yum update and it gave an error.

Dear Locutus, thank you very much for your help!

I wrote an answer a few minutes ago and hit the Save button and it said it was going to be reviewed. I guess it’s because I wrote the name of the company that the VPS belongs to.

Distribution is Centos 6. I have been running it for a few months and lately it’s not been accessible so the other day I decided to restart it so that might be accessible again. After the restart the site on the vps was gone.

9091 port was used in ssl.conf file. After changing it and changin Listen directive to *:80 and servername to *:80, the apache started but the site is not acessible yet. SSH is running on port 22 and it is seen when the command you wrote about is executed.

Okay, seems you got some odd distro specific issues there… Unfortunately I can’t help you with that, since my experience with your hoster and distro are close to zero. Eric might be able to give some advice though, he’s familiar with CentOS.


I still have not found a solution to fix the problem and the site is still down.

I gzipped mysql and public_html folder to move to another server to bring site up but there were no network on the server. I tried /etc/init.d/network restart but I got FATAL: Could not load /lib/modules/2.6.32-358.6.2.el6.x86_64/modules.dep error again.

Any idea how to fix the problem to move the files to another server to get rid of the server and make the site online again? Or is there any way to get the files out of the server? I’ll also ask DO Support Team to move the files for me but I don’t think they will do as they say they are not managed server company and do not do that kind of help. :frowning:

Any suggestions?

Best Regards.

I wrote to their support again and let them know the error and they replied that it was kernel error which was because of yum update. The support member wrote me steps to take in order to make the server boot with the last installed kernel. I did what he wrote to me and it fixed the problems and the server is up and running again!

Thanks for your time to try to help me!

Warm Regards.