Ne ServerAlias created, cant add now

SYSTEM INFORMATION
OS type and version UBUNTU 20.04
Webmin version LATEST
Virtualmin version LATEST
Related packages SUGGESTED

Recently I moved to a new VPS. 3 domains, all went well I thought. But now I have found a strange error that I dont know how to fix
For one of the domains, no ServerAlias for the www was created. Only the servername. When I tried to add it to the apache domain config the webserver cant restart. When I take it away again it restart without any problem.
What do I do wrong

@Havouza15,

It’s likely an easy solution to fix, Apache does a validation when it starts up and therefore won’t start if there’s a configuration error found.

I’d be happy to assist you with getting things working, drop me a line. I have a special intro rate for Virtualmin users.

*** Technical Support, Server Management, Professional, Affordable, Reputable https://tpnassist.com ***

Well, why should I pay. I ask the question in this forum just to avoid to pay. And I am sure I can find a solution using Google. This has happened once and not after. I can live with it if I must

@Havouza15,

You most certainly are not obligated to pay for support, perhaps someone else will spend the time to help you troubleshoot the matter. Giving an attitude certainly won’t help your case however. I simply offered you an option.

1 Like

If you used these forums a bit you will noticed tpnsolutions has offered a paid solution to issues, its what he does. Don’t take offense.

So many try to make an extra buck. But when the first and so far only answer I get in the forum is an offer for paid support I react. But as so many times before I solved the problem myself. Case closed.

Den tors 22 sep. 2022 04:48stefan1959 via Virtualmin Community <noreply@forum.virtualmin.com> skrev:

@Havouza15 is right imho. paid support is offered through Virtualmin Pro, and there’s a whole section in this forum for virtualmin contractors, called “Jobs”…
offering your business card/paid support in every post in a community forum, is just noize/spam.
imagine if everyone willing to help, just posted links to paid support instead… what’s the point of a community forum then?

just 2c,
d.

@dimitrist,

If you do a bit of searching you will find that I do offer a wealth of tips, outright solutions and other free support when I deem it appropriate.

My general policy is that if it’s a simple Virtualmin feature that’s been overlooked and/or adjustment, I’ll often assistant free of charge. Also, if the issue is determined to be caused by an apparent bug I may also deem this to be a free support case as a favor to the developers.

However, as much as I’d love to dedicate dozens of free hours for free, I earn a living providing troubleshooting and technical support so when a matter falls outside the scope above I do feel it’s appropriate to offer as a paid service. My rates for matters picked up from the forums is 50% less the rates I charge my regular clients.

I do not require someone to accept my assistance just as anyone is entitled to refused or decline any response to their request for help.

One point that should be noted that seems to have been overlooked in my original response. I did provide a tip in my initial response which with a little searching around could have helped lead to a solution. If however someone wants me to put the hours of work in, then a small fee for doing so isn’t inappropriate. Again, just an option not an obligation.

No offense is taken when my offer is declined or ignored. How it was declined was the only issue I took.

Anyways, bigger fish to fry. Take care and good luck.

1 Like