Nameservers questions / help

Hello all

Right here i go and am sorry if you dont understand lol am trying my best to explain this :slight_smile:

I run a few sites and in there settings for there domain i used to add the nameservers ns1.mymatesite.com and ns2.mymatesite.com

Now my mate has stoped running this nameserver
So i have no idea what i can do now
My Main Domain is myanimeisland.com is there a way i can add ns1.myanimeisland.com and ns2 and all will work?

also could i add this for all my domains
ns1.myanimeisland.com for say nekotron.com etc…

Sorry its bloody hard to type and explain this problem
ive got 123-reg to register the name servers ns1.myanimeisland.com and ns1 to my servers IP
I did a test and added ns1.myanimeisland.com to vodkaholic.co.uk but it just gives me “Oops! Google Chrome could not find vodkaholic.co.uk” when i look at the site

Hope you can understand some of this post
Thanks alot
Mike

So it sounds like you’re saying you need a place to host a set of nameservers for the domains you’re hosting.

Yeah, you can do that on your own server without a problem – though, just remember that you can’t just make up the names “ns1.myanimeisland.com” and “ns2.myanimeisland.com”.

In order to use those, you need to do two things:

  1. In Virtualmin, go to Services -> DNS Domain, and add an “Address” record for each of those

  2. Go to your domain name registrar, and you’ll need to register each as nameservers with your registrar. Once they’re registered as nameservers, you’ll be able to add them as the nameservers for your domain “vodkaholic.co.uk”.

After that, your server should start answering DNS lookup requests for that domain (and any other domain you add those nameservers to).

-Eric

Hi Eric
Many Many Thanks for that glad you understood me :smiley:

One more question if i may
You say “In Virtualmin, go to Services -> DNS Domain, and add an “Address” record for each of those”

Does this mean i will have to add ns1.myanimeisland.com and ns2 in all the domain services i run? or only in the myaniemisland one?

Thanks

Edit also i did register them with my domain place but i get this on lookup

Retrieving DNS records for ns1.myanimeisland.com
Attempt to get a DNS server for ns1.myanimeisland.com failed: ns1.myanimeisland.com does not exist in the DNS

One more question if i may You say “In Virtualmin, go to Services -> DNS Domain, and add an “Address” record for each of those”

For all the domains on your server, you should only need two nameservers… ns1.myanimeisland.com and ns2.myanimeisland.com.

So you’d only need to do that once, for the myanimeisland.com Virtual Server.

Attempt to get a DNS server for ns1.myanimeisland.com failed: ns1.myanimeisland.com does not exist in the DNS

It sounds like it’s not seeing the ns1 and ns2 Address records added to your servers DNS yet. Make sure you add those first. If you did add them, you have to hit “Apply Zone” afterwards to make them take effect.

-Eric

Ok i hit Apply Zone and this came up

“NDC command failed : rndc: connect failed: 127.0.0.1#953: connection refused”

Hmm ? anyideas
Thanks

Some folks mentioned a possible solution for that problem here:

http://www.virtualmin.com/node/10705

Also, you may be able to get around it by restarting BIND from the command line using the init scripts.

-Eric

Hi Eric thanks for the link but am a noob what is init scripts sorry
I restarted Bind in VM but same problem so i guess its not that

Edit indeed my file was Bind i set to root again and didnt get the error restarted also seem to have worked

Vodkaholic.co.uk still shows nothing tho
Thanks

You can use intodns.com to get a DNS report for your domain, and hopefully offer some insight into what’s going awry:

http://www.intodns.com/vodkaholic.co.uk

According to it, it’s not seeing Address records for your nameservers.

Remember that for this to work, the DNS for myanimeisland.com would need to be hosted on your server as well… it doesn’t appear to be, as the nameservers for that domain point to ns1.hidnet.org.uk and ns2.hidnet.org.uk.

So when those lookups are taking place, they aren’t querying your server, they’re querying hidnet.org.uk.

-Eric

it seems ns1. + ns2.myanimeisland.com are not registered as nameservers at your registrar (or at least do not have IP’s entered) as they have no glue.

The IP’s belonging to those nameserver need to be sent out into the world. Only the registrar can do this.

Hey ok forget ns1 + ns2.myanimeisland.com

Am using ns1 and 2 .vodkaholic.co.uk now
Ive added this in the nameservers for the domain also ive asked my domain host to register these as nameservers to the following IP 188.165.217.101

I still see nothing on vodkaholic.co.uk but am guessing its not registered the nameservers yet
Thanks

The NS and A entries from the registrar are set correctly and propagated now. Your sever 188.165.217.101 though says SERVFAIL when querying *.vodkaholic.co.uk.

Seems the BIND on that host is not yet correctly configured to serve that domain. It might help to use the Webmin BIND module’s functions Check BIND Config globally, and Check records for the zone, to see any errors.

Hi Locutus thanks for the help

I went to webmin >> servers >> BIND DNS server
clicked on vodkaholic.co.uk than i hit check records

If this is the what you meant it give this
No errors were found in the records file /var/lib/bind/vodkaholic.co.uk.hosts.

Okay, then click “Check BIND Config” in the main screen, it’s the second icon to the right on the bottow row. The error might be in BIND’s main config file itself.

If there’s no error reported there as well, try restarting BIND and then check /var/log/syslog or other logs there where BIND possibly records what it has to say. :slight_smile:

No errors were found in the BIND configuration file /etc/bind/named.conf or referenced zone files.

This is the log after a restart

Nov 11 01:33:11 ks312361 named[8595]: shutting down Nov 11 01:33:11 ks312361 named[8595]: stopping command channel on 127.0.0.1#953 Nov 11 01:33:11 ks312361 named[8595]: stopping command channel on ::1#953 Nov 11 01:33:11 ks312361 named[8595]: no longer listening on ::1#53 Nov 11 01:33:11 ks312361 named[8595]: exiting Nov 11 01:33:11 ks312361 named[8788]: starting BIND 9.6-ESV-R1 -c /etc/bind/named.conf Nov 11 01:33:11 ks312361 named[8788]: built with '--prefix=/usr' '--build=x86_64-linux-gnu' '--host=x86_64-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var/run/bind' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--enable-ipv6' 'build_alias=x86_64-linux-gnu' 'host_alias=x86_64-linux-gnu' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -DNS_RUN_PID_DIR=0 -O2' 'LDFLAGS=' 'CPPFLAGS=' 'CXXFLAGS=-g -O2' 'FFLAGS=-g -O2' Nov 11 01:33:11 ks312361 named[8788]: adjusted limit on open files from 1024 to 1048576 Nov 11 01:33:11 ks312361 named[8788]: found 8 CPUs, using 8 worker threads Nov 11 01:33:11 ks312361 named[8788]: using up to 4096 sockets Nov 11 01:33:11 ks312361 named[8788]: loading configuration from '/etc/bind/named.conf' Nov 11 01:33:11 ks312361 named[8788]: using default UDP/IPv4 port range: [1024, 65535] Nov 11 01:33:11 ks312361 named[8788]: using default UDP/IPv6 port range: [1024, 65535] Nov 11 01:33:11 ks312361 named[8788]: listening on IPv4 interface lo, 127.0.0.1#53 Nov 11 01:33:11 ks312361 named[8788]: could not listen on UDP socket: address in use Nov 11 01:33:11 ks312361 named[8788]: creating IPv4 interface lo failed; interface ignored Nov 11 01:33:11 ks312361 named[8788]: listening on IPv6 interface lo, ::1#53 Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 254.169.IN-ADDR.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 2.0.192.IN-ADDR.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: D.F.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 8.E.F.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: 9.E.F.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: A.E.F.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: automatic empty zone: B.E.F.IP6.ARPA Nov 11 01:33:11 ks312361 named[8788]: command channel listening on 127.0.0.1#953 Nov 11 01:33:11 ks312361 named[8788]: command channel listening on ::1#953 Nov 11 01:33:11 ks312361 named[8788]: additionally listening on IPv4 interface lo, 127.0.0.1#53 Nov 11 01:33:11 ks312361 named[8788]: could not listen on UDP socket: address in use Nov 11 01:33:11 ks312361 named[8788]: creating IPv4 interface lo failed; interface ignored Nov 11 01:33:11 ks312361 named[8788]: zone 0.in-addr.arpa/IN: loaded serial 1 Nov 11 01:33:11 ks312361 named[8788]: zone 127.in-addr.arpa/IN: loaded serial 1 Nov 11 01:33:11 ks312361 named[8788]: zone 255.in-addr.arpa/IN: loaded serial 1 Nov 11 01:33:11 ks312361 named[8788]: zone babylon5rpg.com/IN: loaded serial 1289353370 Nov 11 01:33:11 ks312361 named[8788]: zone myanimeisland.com/IN: loaded serial 1289365276 Nov 11 01:33:11 ks312361 named[8788]: zone rpg-central.com/IN: loaded serial 1289352156 Nov 11 01:33:11 ks312361 named[8788]: zone stargatecommandrpg.com/IN: loaded serial 1289357904 Nov 11 01:33:11 ks312361 named[8788]: zone localhost/IN: loaded serial 2 Nov 11 01:33:11 ks312361 named[8788]: zone vodkaholic.co.uk/IN: loaded serial 1289399469 Nov 11 01:33:11 ks312361 named[8788]: running Nov 11 01:33:47 ks312361 pdns[20553]: Not authoritative for 'vodkaholic.co.uk', sending servfail to 92.114.98.140 (recursion was desired) Nov 11 01:33:47 ks312361 pdns[20553]: Not authoritative for 'vodkaholic.co.uk', sending servfail to 92.114.98.140 (recursion was desired) Nov 11 01:33:47 ks312361 pdns[20553]: Not authoritative for 'vodkaholic.co.uk', sending servfail to 92.114.98.140 (recursion was desired) Nov 11 01:33:47 ks312361 pdns[20553]: Not authoritative for 'adobe.com', sending servfail to 92.114.98.140 (recursion was desired) Nov 11 01:33:48 ks312361 pdns[20553]: Not authoritative for 'vodkaholic.co.uk', sending servfail to 209.85.228.84 Nov 11 01:33:54 ks312361 kernel: IPv6 addrconf: prefix with wrong length 56

Aaargh! Please embed that log in tags! I officially refuse to read it before you do that. :wink: You’ll see what I mean I once you do that. :slight_smile:

Okay, that’s much better. :wink:

First thing I see is an error about “could not listen on UDP socket, address in use” for the localhost. Odd thing, since it seems to be reacting to queries (at least on the eth) later. Might want to check, after shutting BIND down, if any other processes are listening on 53 (netstat -lupn).

Then, the configured zones seemed to have loaded fine, but queries were rejected with not authoritative for.... It’s possible there’s something wrong with the respective zone.

Can you please post the contents of /etc/bind/named.conf.local?

[code]//
// Do any local configuration here
//

// Consider adding the 1918 zones here, if they are not used in your
// organization
//include “/etc/bind/zones.rfc1918”;

zone “rpg-central.com” {
type master;
file “/var/lib/bind/rpg-central.com.hosts”;
allow-transfer {
127.0.0.1;
localnets;
};
};
zone “babylon5rpg.com” {
type master;
file “/var/lib/bind/babylon5rpg.com.hosts”;
allow-transfer {
127.0.0.1;
localnets;
};
};
zone “stargatecommandrpg.com” {
type master;
file “/var/lib/bind/stargatecommandrpg.com.hosts”;
allow-transfer {
127.0.0.1;
localnets;
};
};
zone “myanimeisland.com” {
type master;
file “/var/lib/bind/myanimeisland.com.hosts”;
allow-transfer {
127.0.0.1;
localnets;
};
};
zone “vodkaholic.co.uk” {
type master;
file “/var/lib/bind/vodkaholic.co.uk.hosts”;
allow-transfer {
127.0.0.1;
localnets;
};
};
[/code]
Thanks

Okay, now please the contents of /var/lib/bind/vodkaholic.co.uk.hosts, I’m quite certain we’ll find errors there.

$ttl 38400 @ IN SOA ks*******.kimsufi.com. root.ks*********.kimsufi.com. ( 1289399469 10800 3600 604800 38400 ) @ IN NS ks***********.kimsufi.com. vodkaholic.co.uk. IN A 188.165.217.101 www.vodkaholic.co.uk. IN A 188.165.217.101 ftp.vodkaholic.co.uk. IN A 188.165.217.101 m.vodkaholic.co.uk. IN A 188.165.217.101 localhost.vodkaholic.co.uk. IN A 127.0.0.1 webmail.vodkaholic.co.uk. IN A 188.165.217.101 admin.vodkaholic.co.uk. IN A 188.165.217.101 mail.vodkaholic.co.uk. IN A 188.165.217.101 vodkaholic.co.uk. IN MX 5 mail.vodkaholic.co.uk. vodkaholic.co.uk. IN TXT "v=spf1 a mx a:vodkaholic.co.uk ip4:188.165.217.101 ?all" ns1.vodkaholic.co.uk. IN A 188.165.217.101 ns2.vodkaholic.co.uk. IN A 188.165.217.101

Ive stared out my server name *****
Thanks again for the help

Okay, I see a problem there. What is “kimsufi.com”?

The NS entries at the NIC say that ns1.vodkaholic.co.uk., as in your server, is the authoritative nameserver for that domain, but in your zone file, you delegate the SOA and the NS to some system at a domain (kimsufi.com) which is not known to BIND. That is bound to confuse it. :slight_smile:

The entries at the NIC must match what your zone file says for SOA and NS.