Mysqladmin: connect to server at 'localhost' failed when doing force log rotation

**OS type and version:**Debian 10
Webmin version: 1.973
Virtualmin version: 6.16
MariaDB 10.3.29

Hello all,
Today when I try to do Force log rotation I get myql error

What I did was I went to server - MySQL Database Server and change the administration password. after hitting the stop server I got another error

However, I did manage to start the server back but still no luck with log rotation I still get the same error

While I wait for some expert answers, I try to search for my.cnf, but there was no such file under


I open the debian.cnf, and this is what I saw

It says “do not touch,” but I’m stubborn, so I did touch it and added my MySQL password. Saved and restart the MySQL server.

No issues, so I try to force log rotation, and BOOM! It worked.

I don’t know if that is the correct way to solve this problem by adding my password in a config file where it says DO NOT TOUCH. :grimacing:

Correct me if I’m wrong before I get into more troubles

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.