mySQL remote access problem and error

OS type and version AlmaLinux 9.4
Webmin version 2.111
Usermin version 2.010
Virtualmin version 7.10.0
Theme version 21.10
Package updates All installed packages are up to date

remote acces to mnaria db/mysql - I had it working but now its changed. I’ve tried for hours to get remote access to mysql via tcp/sockets ssh. No joy at all.
I get access denied for user messages when trying to connect via sequel ace.
Permissions seem fine.

The current issue is that I added my remote ip on the db edit user page when it was working. Now i have tried to change this to ‘any’ host i got an error saying couldnt change name pointing to line 359.

The UI for users doesn’t make sense to me as I have sites running accessing the databases but in the mariadb users list they have permissions = none? How can the CMS be reading and writing if permissions are none?

I’m hoping someone can explain if the mariadb users list is actually not where the permissions are then where are they set? Im so lost

Might be firewall

Just set it to that may work however with mariadb I had to edit the correct config file and add the above to the correct config block but for some reason with mysql the gui worked… don’t forget to restart mysql/mariadb after making changes to the configuration

Added ip and port and removed. No dice.
Weirdly it just started working so i removed and added firewall ip and port with no differerence.

The one difference i did was to remove a db user with the same name but with explicit privileges - and now it works despite the UI permission user list saying user has ‘none’ on permissions

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.