MySQL Memory upgrade - reselect MariaDB/MySQL database size optimization in Post-Installation Wizard

Operating system: Ubuntu
OS version: : 20.04

In my server I choose 1GB of memory for the MySQL server during the installation process, now I want upgrade it to 2GB, What changes do I need to make?

Thanks!

Virtualmin -> System Settings -> Re-run Installation Wizard.

Very carefully and without changing any other setting inadvertently, keep hitting Next till you reach MariaDB/MySQL database size and then choose the appropriate option there.

thanks for the answer!

Just in case this is a production server, is risk free that method?

Yes, I have done this more than once, no problem.

Not this time, I have this issue:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active ..

Your system has 7.77 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB.

Virtualmin is configured to setup DNS zones, but this system is not setup to use itself as a DNS server. Either add 127.0.0.1 to the list of DNS servers, turn off the BIND feature on the Features and Plugins page, or disable the Check resolv.conf option on the Virtualmin Configuration page.

.. your system is not ready for use by Virtualmin.

Any ideas?

Very easy to fix - and the issue is unrelated to MySQL database size optimization.

Here is what you need to do to fix this error: Virtualmin -> Settings -> Virtualmin Configuration: Advanced Options - Check resolv.conf for this system to no. That should fix the error.

Then proceed with Re-run Installation Wizard. Sorry about the scare!

YES! hahaha

Thanks!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.