MySQL Error : Can't create/write to file '/tmp/#sql_6b73_0.MYI' (Errcode: 30)


I have a centos 6 server which i set up with webmin originally and then installed virtualmin to run virtual servers for my websites. I have a forum installed which has been working completely fine for the past couple of days without any problems, then over last night I ended up with this error:

MySQL Error : Can’t create/write to file ‘/tmp/#sql_6b73_0.MYI’ (Errcode: 30)

Im the only one that has access to my server so nobody could have changed settings by mistake. I have tried checking the /tmp permissions and as far as Im aware they are set to write etc. I have tried restarting mysql database server through webmin but now that also comes up with an error.

I have no idea how to fix this as Im a complete newbie here.

Any help would be appreciated.


First, installing Virtualmin on top of an existing system can be problematic, especially for “newbies”. :slight_smile: You’ll need to configure lots of things manually. Recommended is using the Virtualmin installer script on a fresh OS.

What’s the output of ls -l /?


Also, there’s some info here on MySQL’s “Errcode 30”, does any of this help: