Mysql backup issues - virtual server backups

Hey there,
Yesterday i lost some data after i used restoration backup from cron.
I noticed that backup for mysql have only 1kb in the backup.
I tested manually from webmin to backup another data from other website and same results.
If i restore entire virtual server, after restore when i check database it says 0 tables.
However i did not received any errors during backup-restores.
Only database content is missing from all backups.
mod_fcgid: error reading data from FastCGI server
[Mon Apr 02 17:38:14.333905 2018] [core:error] [pid 24278:tid 139664902428416] [client] End of script output before headers: index.php

This errors i get after restore virtualserver.
I suppose it throws that error because mysql database is empty.
Any suggestion how can i save databases for the rest of websites?
Also another issue appearing into one website with website option at under php 7 info shows no modules

Configuration errors for PHP 7.0 Directive ‘asp_tags’ is no longer available in PHP, Directive ‘asp_tags’ is no longer available in PHP

I solved php issues, but still mysql from backups save data 1kb file sql. The only way to save data is to install phpmyadmin and save tables from there.
In virtualmin backup features not working.
Anyone have these problems in virtualmin 6.02-3 ?

Ok, i solved issues with backup mysql issues.
Mysql for some reasons was missing performance_schema tables, and cron tasks for backups wasn’t able to do backups properly. But no errors was thrown by virtualmin, he just backup a mysql file 1kb empty with no tables.
I solved problem by running as a root admin command mysql_upgrade -u root -p --force
Then Webmin—> Servers ----> Mysql Database Server ----> MySQL Server Configuration press save&restart mysql (if MySQL System Variables list is empty)
Seems problems with php are gone at this moment after this upgrade mysql. I also modified mpm_event module configuration that caused some php errors due to overload memory in php fastcgi.