mysql accounts

i’m running the 2.61 in webmin.
When I set a user to be able to create databases, there is no way for him to do so.

The solution I found was to manually go into the webmin users, into the mysql config on the user account and manually enable him to add databses.

Is this a bug?

You will have to give them access the the mysql module in webmin. Do this from Webmin -> Webmin Users -> User - [[check]] MYSQL Database Server.

Sorry, I skimmed your post. You can set new users to automatically have access under Servers -> Virtual Servers -> Module Config -> Find "Feature modules available to domain owners" and then directly under that is MySQL Database Server (for database) (y) Yes ( ) No

If you have Yes selected then it should give them access to the mysql module by default.

sorry maybe I didn’t explain well.

It gives the access to the mysql module, but does not give the m access to create new databases even if I select that setting when creating their account.

Try logging in to webmin as the domain user, go to Servers -> Virtualmin Virtual Servers, then go to the domain, then to "Edit Databases". You can control addition and deletion of databases from here.

Is there a way to allow the user to add his or her own databases instead of having to get the server owner involved?