My SSL plugin asking me to add location to nginx

SYSTEM INFORMATION
Debian 12 REQUIRED
Virtualmin 7 REQUIRED

Hello I am getting error message from my wp ssl plugin asking me to add some code to my nginx folder but I don’t know how to add it the message say:

The code to block code execution in the uploads folder cannot be added automatically on nginx. Add the following code to your nginx.conf file:
location ~* /uploads/.*.php$ {
return 503;
}

how to add it and where and how to edit it to the correct path if needed

This is an error in WordPress (or more likely one of its plugins)
the error, what little you have presented, is suggesting something like a “503” error and some php source file in an “uploads” sub directory. Are you attempting to use a WP plugin to upload something?

thank you for your answer there is some mistake it is not error message it is notification message to add this line conf file in nginx but I don’t know where and how (like should I edit it)
can you please advise

An “error message” is what you called it as.

It looked incomplete and there was little to go on.

Most of the nginx settings can be accessed in Webmin -> Servers -> Nginx Webserver but you should understand what a nginx webserver is all about before going there. In particular, nginx is not Apache and should not be confused as such. It still looks, to me, that something is choking on the code being fed to your system by your WP setup (plugins).

Have you just imported code from a WP site? was that code on an nginx site? or was it some dumb setup on an Apache site - with all of its now useless .htaccess files? nginx does not use or want such things.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.