My server is hating me! (download speed)

I am totally lost, frustrated and have no Idea what to do next.

My server is a VPS one of it’s IP is here that is serving up my /var/www/ folder.

I added a 15M picture for testing - my brother in Calgary will load the page instantly (has 50mbps connection) I can only download at 10-20kbps (I have an average of 860kbps connection) But still get full download capacity from say downloading a disc image.

I also setup one of my (not so used) domains as a test today, it has a fake 1M jpg. I load the page in 90 seconds yet pingdom gets it in 1.71 second. I am so lost.

Why in the world would my server be restricting me? Today it has been dropping my ssh sessions like crazy too.

Any Help would be appreciated, I don’t even know what to test anymore.

tests by and also show my internet connection as “normal”

First you should try a different computer connected to your Internet that’s slow when fetching files from your server, to determine if your computer or your connection is the culprit. You should repeat all tests several times, at different times of day, to rule out temporary network congestion between your home ISP and your server.

If those tests confirm that your home connection is slow to your server, but fast to everything else, then I suppose there’s some kind of routing/network problem along the path between your home and your server. Your ISP or hoster might be able to give you information there.

Note that on a VPS, usually many customers share one physical connection. So if your VPS neighbors are hogging the network, your server will slow down.

I have been testing like crazy - all my computer here are slow, through the router or directly attached to the modem. Sites like this one, google, ubuntu, banking all run “normal”

My sites on my old shared host, Hostgator are moving at a crawl (,, so I wanted to get them over to the new server, but it is crawling, but it seems like it is crawling just for me as my brother and maybe you are getting things fine. (other then the hostgator sites, they are actually sucking)

I just disabled all my Piwik tracking as I thought it may be holding things up but made no difference.

Does webmin/Virtualmin have any sort of bandwidth throttling?


What you’re seeing could be an issue with your ISP, or your Internet connection.

While there’s certainly room for improvement, the testing I did with the domains you mentioned, I certainly wouldn’t consider them “crawling”.

While Linux can perform bandwidth throttling, that’s a fairly advanced area, and to my knowledge Webmin/Virtualmin doesn’t provide any sort of front-end to that.


Webmin/Virtualmin certainly does not do any bandwidth limiting by default, and certainly not to specific remote hosts like your home connection. You might want to contact your ISP and give them some details about what you tested. You might also want to use “winmtr” on Windows to trace a route to your server. Connection issues might become apparent there.

still not sure what to think today - has a page load time of 13.6 Minutes. It should only take about 18 seconds with my internet connection.

Can anyone else see how fast that page will load (if you use the network tab in developer tools of chrome/chromium/safari it will tell you exactly)

For me, the HTML takes 250ms, the image 17,846 seconds (at home, 10 MBit downstream DSL).

If it takes 13 minutes for you, on multiple computers, there’s definitely something wrong with your Internet connection, specifically to your server.

Have you tested tracing the path with WinMTR meanwhile, like I suggested?

double post - delete

I am on linux(Ubuntu) or Mac so no I have not used WinMTR

Today I got fed up and drove down to the fire hall to see what would happen there (different ISP altogether)

With only a 1MBps speed it would max it out and get the page in 1.4 minutes as expected. I have an issue with my ISP. Time to make a call to tech support, after I drive back home.

sigh, I hate this stuff.

Thanks for the help so far. (the biggest relief is knowing that I am the only one with the worst download speeds ever - but only for about 50% of the sites I visit, which is very odd!)

Well, even better, on Linux the command is just “mtr”. :slight_smile: It comes from Linux, WinMTR is a port to Windows.

well, turns out it was just my ISP - got a new modem and everything is 100% again.