My clients access the virtualmin shell automatically as root

you do not see

?

no, users don’t see the terminal by default, which is why I was trying to add it.

I didn’t want to let them access it through an external client.

there is something you have done somewhere as the terminal is a default item … did you change anything at all when you did the original setup ?

I just change nameservers during the initial setup wizard.

do you think it would be helpful to try reinstalling virtualmin on the vps with a fresh install of ubuntu?

I would like to avoid doing that, but if it can solve the problem I will do it.

if you could run up a virtual box on your home pc and install virtualmin there, then back up a domain from your live system and restore it to the new virtualbox instance & see if that works, if it does there was a problem with the install … if it fails that would indicate a problem with a template/plan or some setting that is carried over from the backup

1 Like

I tried reinstalling virtualmin from scratch, but by default I didn’t have terminal, however, I found out how to put it in without having the problem of root permissions:

As @Joe had suggested, add the terminal module from:

Virtualmin menu with affected domain selected → Administration Options → Edit Owner Limits → Other restrictions → Extra Webmin Modules → add “shell"

was wrong and just dangerous.

To add them just needed to change the default template server, which in my case, by default even after a clean install the terminal was set to “no”.
And just setting it to “yes” was enough to add terminal to my users without adding root permissions.
Here’s how you can do it:

Virtualmin → System Settings → Server Templates → Default Settings (or the one you use) → Administrator’s Webmin Modules

These days I will test the terminal thoroughly, if it has no problems I will select this message as a solution. :grin:

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.