MX record improperly adds domain name to

I’m trying to setup Office 365. I need to create an MX record for

It should be: MX 0

But the domain name is automatically added to the end of the record MX 0

Is there a way to prevent this domain addition at the end of the record?

The server was incorrectly set to enable mail for the domain. Once I disabled mail for the domain the DNS record for offsite Outlook mail was formed correctly.