Multiple copies of email sent during drafting

When I use my email client (Applemail) I can draft and send emails without problem. When I try to send emails from Usermin, it regularly saves the email as a draft as I am typing but also tries to send the mail while saving it. It even does it when I am trying to type in the To: address resulting in several server failure emails showing the partially completed email address as the error as it is not recognised.

If I type a multi line message, It sends a copy for almost every line so a ten line email to a long email address has generated 6 error emails and 12 copies of the email in the recipient email account (mine as I am setting the system up and still testing it).

Is this a bug or are my configuration settings causing this?

Never heard of this, and I can’t reproduce it. I can’t think of any configuration in Usermin that would cause it to act this way, but maybe something in the new hotkeys behavior is acting weird on MacOS (I don’t have any Macs to test on).

Can you try turning off hotkeys in “Theme Configuration” and see if it persists. If it stops, we’d need to loop Ilia into the conversation, as I have no idea how the hotkeys work.

Hi Joe,

Did an email with hotkeys on and it sent 3 copies plus at least one before the email address was inserted. I then turned hotkeys off and tried again and it was the same. Do not know if the configuration change is immediate so will try again after a logout and login.

No, makes no difference. Are there any logs I can send that might identify what is going on?

By the way, I also turned on the automatic spell checker but it does not appear to do the check until after the message has been sent! It could be because the error it is finding is in my signature, the name xorex and the use of Admin in lieu of administrator?


System hostname ( Operating system Debian Linux 8
Webmin version 1.941 Usermin version 1.791
Virtualmin version 6.08 Authentic theme version 19.45

Do you mean that if you use the mail app from iOS / macOS / etc that if you draft a message that it gets send even if you just save it?
Did you send the mails via webinterface (roundcude /etc) or did you setup the mail inside your mail app on your device?
You could check the log files inside /var/log/ .

What makes you think that the message is being sent in 3 copies? New mail composer is indeed saves the draft as typing stopped but it shouldn’t send anything until you click send button.

What browser are you using? If you use Safari, does the same happen in Chrome or Firefox, for example?

Is there a way you could send me a private link with video-screencast?

Hi Carson

This is only happening when I se the Usermin interface. Apple mail works fine. I would rarely use Usermin but thought what I found should be reported as I will want to use it from time to time.

Hi Ilia

Here are 2 shots of my AppleMail showing the multiple emails received as I was typing them in usermin:

And here are 2 pictures of my usermin account showing the emails it sent:

Finally, here is a failure email for the first mail sent halfway through typing the address (geoff@bouti):

Will now try with Chrome and Firefox.


I have taken Firefox off this machine so cannot test it but chrome did not even send the email when I finished typing it!

This may be my setup but ti seems strange that safari (I just checked) sent two emails as I typed it and chrome sent none.

As an aside, the email sent by Safari did not include my signature that it questioned through the spell checker AFTER I tried to send the email.

If it only happens with Safari, then there is a setting in Safari which triggers that.
Either try to reset Safari (I doubt it will fix that) or use another browser if you want to use the usermin mail system.
You could also google (or other search engines) that issue or similarities.

All of those issues, including Safari bug, should be sorted out starting from theme 19.50-beta3 (already available from GitHub). Could you please double check?

OK will take a look this weekend. Can I force the upgrade to the git version?

Yes you can. When you installed the necessary tools for it, you can either upgrade to latest stable or lates beta. There are two buttons for that.

Hmmmm. I have got and curl installed but when I try to update I get an error about no connection to github also about rate limit. How do I use the manual update script?

OK. I had recursion - no set. Changed to recursion - yes and it worked.

Hi Ilia,

Sorry for the delay. I forced the upgrade and prepared and sent an email very slowly to allow multiple saving of the draft and this time it did not send any half completed emails but behaved correctly and saved the draft for me until I sent it. It seems your change has worked. Thanks. I will keep an eye on it for a while but only contact you if there is a recurrence of the problem.

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.