Multi PHP Version Virtualmin Centos 7.8.2003

Webmin version 1.953
Usermin version 1.802
Virtualmin version 6.10

Trying to configure Multi PHP version in a Virtualmin server I got this message:

This virtual server is using the mod_php execution mode for PHP, such does not allow per-directory version selection.

I edited the server template (PHP Options) and set it to FCGId (run as virtual server owner).

After that I run Re-Check Configuration, and get this Message:

The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active

Your system has 15.51 GiB of memory, which is at or above the Virtualmin recommended minimum of 256 MiB.

BIND DNS server is installed, and the system is configured to use it.

Mail server Sendmail is installed and configured.

The Read User Mail module is not setup to use the Sendmail mail server. Either adjust its module configuration to match, or change the Virtualmin configuration.

… your system is not ready for use by Virtualmin.

Does Anybody knows how to solve this issue?


Orlando Gautier

You changed Virtualmin to use sendmail. This is a bad idea (and, potentially a very bad idea) unless you really know what you’re doing. I don’t know how safe/easy it’ll be to switch to Postfix (the default), as it depends on whether you’ve setup new domains or email addresses since switching. There is no accommodation for migrating back and forth between the two mail servers…the intention is that you stick with the same mail server for the life of the server.

If you meant to switch to Sendmail, then switch the Read User Mail module to work with whatever mail format and server you’re using, as the message says.

Hello joe,

I´m really new using Virtualmin and I just trying to setting it up to work. Actually I do not have any running domains. I´ve change Sendmail to Postfix (the default).

Now when I tried to Re-Check configuration, I get this message:

A problem was found with your Postfix virtual maps : No map sources were found in the Postfix configuration

Do you know how can I solve this?


Orlando Gautier

It sounds like you didn’t install using the automated install script. Start over with a fresh OS install and the use the install script found on our Download page. There’s no reason to manually install and configure everything…and you’re going to have a terrible time doing so if you’re not an expert.


I installed using the script, and I did over a fresh Centos 7 OS.

Should I start over?


Orlando Gautier

If you’re not actually hosting any sites yet, then I think a fresh install almost certainly would be the easiest and fastest solution.

Be sure to update CentOS itself before installing Virtualmin (that’s the yum -y update step on the linked page). So the underlying OS should be “fresh,” but also up-to-date.


Something definitely went wrong. There would have been errors, or all the steps didn’t complete (the steps are labeled clearly so you can know if it fails early…). There’s no way a successful installation looks like what you have. You can’t ignore errors during installation.

Yes, and pay attention during installation. If problems occur, that’s the time to ask for help.

Thank you very much!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.