Moved Stats, now awstats not complete

Hello, I’ve been banging around this problem for quite a while now and I’m stumped. Most of the default virtualmin settings are as they were, stats and log rotations weren’t modified.

Our server has the / directory on a separate partition than /home/ and all the other files.

That partition is about 50GB large.

Recently I found that the space was getting full, and the two biggest directories were the root’s email, and the var/log folder.

So I went into /var/log/virtualmin and moved all the to a different folder on the server, thinking that moving the date log would be just fine.

Then I got complaints that the awstats wasn’t showing any statistics at all, so I took a look and saw that it couldn’t run because it was the version from rpmforge, so i fixed that and removed awstat and reinstalled it from the approved virtualmin repo.

Now. I’ve tried running

perl /usr/share/awstats/tools/ /home/user/var.log.backup/virtualmin/sitedomainaccess > /tmp/awstatsfile.tmp

and then run that generated file by changing the awstat logfile config for that particular site to this file for just one run. However the best I got was getting the statistics from the date I moved the logs to today…

As a last ditch effort I moved all the files back to their original location, and through webmin tried to regenerate the log, but alas, to no avail, I still have no access to the old logs in awstats.

What steps do I need to do to fix this and how can I move the files out without breaking the stats?

Centos 6.6