Monitoring and email alerts

This is a two part question.

Our Virtualmin server is located at a co-location facility. We have monitoring setup to notify us whenever a website goes down.

  1. How can I change the email address that the alerts come from? They are currently coming from "webmin@localhost.localdomain"

  2. We receive many false alerts every day and ended up shutting the monitoring off on all but he most critical sites. What are some steps I could take to reduce (eliminate?) the false positives?

I don’t have a system with the status monitoring setup here to look at, but there should be an option in the Server Templates to tweak those settings.

The status monitor can produce some false positives, especially depending on the load of your server during the status check.

What I might do is bump up the timeout that the status monitor uses (in the Server Templates), that should help.
-Eric

Thanks Eric. The server can’t be under much of a load, so I doubt that’s the issue. We’ve gone ahead and disabled status monitoring on all non critical websites, that’ll be our temporary solution for now. If I want to bump the thresholds, where would I do that?

Also, any idea how I change the default email address from webmin@localhost.localdomain?

Thanks.

You can set that in System Settings -> Server Templates -> Status Monitoring.

Since it’s a template, I believe that means it only applies to new Virtual Servers, so you may need to disable the Status Monitoring feature (in features and plugins), then re-enable it, in order for it to take effect.

To set the From address, go into System Settings -> Module Config -> Actions upon user and server creation, and look at the "From: address for email sent by Virtualmin" setting.
-Eric

So first off, it sounds as if your hostname may not be setup correctly. Make sure your hostname is setup, and make sure that you have an entry for it in /etc/hosts.

But, that’s not the issue here :slight_smile:

If you set the email address in “Actions upon user and server creation”, and it’s not working when you’re being sent email notifications during the backups, that may be a bug!

So first, I’d double-check that the email setting you added is still in there – that it was saved properly.

If so, I’d recommend filing a bug report using the Bugs and Issues link below.
-Eric

I changed the email in the place you suggested - system settings - module config - action upon server and user creation.

Unfortunately I just received another email alert, this time for backups, from webmin@localhost.local domain.

The subject of the email is "Configuration backup on localhost.localdomain failed"

To clarify my questions \ request further; I need ALL alerts from virtualmin to come from a specific address. Does the setting I mentioned above change the default "from" address for virtualmin outgoing emails? Thanks.

I changed the email in the place you suggested - system settings - module config - action upon server and user creation.

Unfortunately I just received another email alert, this time for backups, from webmin@localhost.local domain.

The subject of the email is "Configuration backup on localhost.localdomain failed"

To clarify my questions \ request further; I need ALL alerts from virtualmin to come from a specific address. Does the setting I mentioned above change the default "from" address for virtualmin outgoing emails? Thanks.