mod_pagespeed and Virtualmin hosts

Hello,

I’m trying to increase the performance of my website and came across mod_pagespeed by Google. Figured they made it so it has to be good.

The problem I have is that when I check my www.site.com/info.php file, the module is not listed as being loaded.

If I do a

httpd -M

It shows that the module is loaded with apache. ( pagespeed_module (shared))

So am I supposed to do anything special in order to make it work with my virtual host?

Thank you!

SR

Howdy,

The PHP “phpinfo()” function would just show PHP modules, rather than Apache modules in general.

If you’re seeing it when running “httpd -M”, that does indeed mean it’s loading, though you may still need to configure it. Details on configuring that module are available here:

https://developers.google.com/speed/pagespeed/module/configuration

Hi Eric,

It seems to be running at the server level but not at the site level:

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
HTTP/1.1 302 Moved Temporarily
Date: Tue, 27 Jan 2015 23:30:24 GMT
Server: Apache
X-Powered-By: PHP/5.4.16
Location: https://www.mysite.ca/eng/
Cache-Control: max-age=31536000
Expires: Wed, 27 Jan 2016 23:30:24 GMT
X-Content-Type-Options: nosniff
Vary: User-Agent
Content-Length: 0
Content-Type: text/html; charset=UTF-8

https://developers.google.com/speed/pagespeed/module/faq#not-rewriting

No improvements and it should be listed as an active mod on my phpinfo page.

How do I load a module at the site level?

EDIT:

Ran wget -q --save-headers -O - http://www.mysite.com/ | head -20

And I now see it. Not sure why it doesn’t show up in my php info page but I dont see any header information in there either so its probably a security feature when I went crazy trying to become PCI compliant.
Thanks!
SR