mod_fcgid timeout issue

I keep have the following issue

[warn] mod_fcgid: read data timeout in 31 seconds

I have raised the limit to 300 via virtual-min and also verified by looking in the virtual servers php.ini and checked the apache VirtualHost for the virtual server and that is also set to “IPCCommTimeout 300”.

If I set the limit to 2 seconds I receive the following in the logs

[warn] mod_fcgid: read data timeout in 2 seconds

It seems to allow and follow any number i set under 30 seconds. But as soon as it is above 30 it seems to just force it self back to 30.

It is a PHP script which needs to run for about 120 seconds, the virtual server is running under FCGId and I would prefer to keep it running in this mode.

Does anyone have any idea whats going on?


You may want to try going into Server Configuration -> Website Options, and in there, verify that the “Maximum PHP script run time” value is set to a high eno ugh number.


HI, Already checked it. It looks like it some times it follows the 300 second limit but some times it goes back to the 30 second limit. I have tried resetting the server thinking maybe it was some of the PHP processes where still running with the 30 second limit but I still getting the issue.