mod_fcgid Rapidleech


I’ve tried configuring a new Virtualmin setup. However, I couldn’t get Rapidleech script to work.

For those who are not sure what it is,

Basically I do not know why the files are not properly transloaded. I believe this could be PHP parsing problem. Anyone here knows what is the proper configuration to have Rapidleech work on Virtualmin?



I’m not familiar with that particular software – but what is the problem you’re having with it, specifically? You mentioned an issue with transcoding – are you seeing any errors? What about in the Apache logs, $HOME/logs/error_log… does anything show up in there?

If you haven’t already, you may want to look at the requirements they list on that site:

Not all of those are defaults on each distro… for example, Ubuntu’s memory_limit defaults to 32MB, whereas the above says it requires a limit higher than that.


Ok, I’ve managed fix the script a bit, but I’m facing output_buffering issue. By default it seems that mod_fcgid has this turned on. How can I overwrite it so that it will be turned off?

you can edit the php.ini file located in your /home/domain/etc/php folder
then restart apache

It’s not working… I’ve turned it off and stuff.

If you don’t believe me, please test this on your own Virtualmin server

        for ($i=0; $i<10; $i++){
                echo "$i\n";
                sleep (1);

This code works on mod_php and every second it should print the numbers 1 by one. It doesn’t work in mod_fcgid…

Anyway to make this work?


After hours and hours of testing and google searching. I’ve came to a conclusion that it COULD be mod_fcgid version problem maybe?

I’ve downloaded a new copy and compiled it myself from apache website,

Now, I simply added ‘OutputBufferSize 0’ to a VirtualHost. It worked!

This initially did not work for Virtualmin self-installed mod_fcgid.

Please check on this?