mod_fcgid output buffering problem solved by switching to FastCGI?

After reading this forum for an extensive amount of time and googling around, i finally decided to switch to Virtualmin (from kloxo). It was mainly cause of Webmin. I love how simple it is to use. Everything you need to edit on a server is orderly placed in a easy to access place. I thought Virtualmin would be the same…

So i install it, and it turns out this is the best choice i ever made. It does not have suPHP but i still dont need to chmod folders cause it comes with something called fcgid along with its “wrapper”. To my limited knowledge of linux, it didn’t matter. It was the next best thing to suPHP. It also came with suEXEC preinstalled, which is perfect for me as i use a Perl+PHP file manager that i have customized myself to run on cPanel servers running suPHP and suEXEc. I “was” happy.

Then i found that it behaves “strangely” when i try to use a dynamic progress bar with file transloader that i am working on. I thought it was my script so i tryed with something i knew works, RapidLeech. However that progress bar failed to load too…

Sorry, not failed, it would wait for a long time then just suddenly go up! I knew it had something to do with mod_deflate and its output buffering. So i went into webmin, Apache module and commented out the line that loads however the problem was still there. So i checked php and the gz output compression was off. I placed a .htaccess file with “SetOutputFilter NONE” still no change. So i started to look around and came accross the issue of mod_fcgid and its 64k output buffering. It does explain why the output just “appeared” at once and then wait again.

I googled and googled and found a load of bullcrap. All it said was to put “FcgidOutputBufferSize 0” in my httpd.conf file:

It gave syntext error.

In this forum, i got a post saying to put “OutputBufferSize 0” in fcgid.conf… didn’t work either. So i went with the most simple solution.

After playing around with the GPL version of Virtualmin (and using google to search this forum) i finally figured out how to manage the templates and others.

I changed from “PHP Execution mode” from fcgid to FastCGI and everything worked.

So this post is for someone like me looking to turn off the ANNOYING bug in mod_fcgid.

Switch to FastCGI wrapper for the features of suPHP, minus the bug in fcgid.