mod_actions Problem

Getting this error when trying to get into the newest Virtualmin. I just upgraded my webmin and virtualmin yesterday.

<i>The status of your system is being checked to ensure that all enabled features are available, that the mail server is properly configured, and that quotas are active …

BIND DNS server is installed.
Mail server Sendmail is installed and configured.

The Apache module mod_actions is either not installed or not enabled.

… your system is not ready for use by Virtualmin.[/i>

At first the module was not enabled… so I enabled it. Still wont work.

I encounter this same error message.

I moved actions.load from /etc/apache2/mods-available/ to /etc/apache2/mods-enabled/ and restarted Apache 2.

I verified that /etc/apache2/mods-enabled/actions.load does contain: LoadModule actions_module /usr/lib/apache2/modules/

In Webmin, I go to Server -> Apache webserver -> Global configuration -> Re-Configure Known Modules, I see that mod_actions does have a checkbox next to it.

Virtualmin continues to report "The Apache module mod_actions is either not installed or not enabled", even though it is.

Seems like a bug to me.

Forgot to say: I am using Debian GNU/Linux 4.0, Webmin 1.350, and the latest version of Virtualmin.

After going to the Re-Configure Known Modules page, did you click the Configure button? That is necessary to have Webmin re-detect installed Apache modules.

Unfortunately this cannot be done automatically / on demand by Webmin, as the process of detecting installed modules is too slow … it requires a call to the httpd -l command, which would be expensive if it had to be done every time the Apache config file was read.

Hmmm… I fixed it like 2 days after that post. Since no one else replied I thought it was just me. I remember I had to either enable or disable some other module and then it just magically worked. I had tried doing the "Re-Configure Known Modules" but that did not help.

Try disabling each of these if you have them enabled


Or possibly I enabled one of these


I remember I had to enable or disable some other irrelevant module but I can’t remember what lead me to try it. I think i had gotten some other error with virtualmin before the mod_actions error.

Clicking Configure in the Re-Configure Known Modules page did solve it for me.

It seems there is a bug in webmin - enabling installed apache mods doesn’t work in latest webmin (1.3.50), at least in Ubuntu 7.04

Could you give some more details on what goes wrong with enabled Apache modules? It works OK for me in Webmin 1.350…

I also have problems with virtualmin detecting apache2 modules… i was just about to submit my issues as listed below…but fixed it by change apache configuration from /etc/apache2/httpd.conf to /etc/apache2/apache2.conf !!

I’m submitting this anyway in case it helps others.

"Used Virtualmin 3.43 on Debian 4.0

I would go into apache and select mod_action, then click configure. then restart apache.

then i would recheck virtualmin. it would then accept mod_actions but complain on the next module (mod_suexec).

I would then go back to apache and the ‘mod_action’ box would not be clicked. if i just click on suexec, and then configure, the virtualmin configuration will complain that ‘mod_action’.

eventually… after finally working out all the modules that were missing, i would click on all of them, configure and virtualmin will accept the configuration and report that the system was ready to use.

However, the checkboxes on the ‘required’ modules remain unchecked in the apache section.

They are all definately there in /etc/apache2/mods-enabled

BTW are they not listed in the Apache Modules section either…"

As mentioned above, this is now fixed by change apache configuration from /etc/apache2/httpd.conf to /etc/apache2/apache2.conf !!