I see it mentioned here on the site but I am unable to locate the place where it is setup, the mobile alerts and mobile access?

If anyone can point me in the right direction that would be appreciated.


Hey Greg,

Mobile access should be automatic–when you login via your phone, it should automatically select the mobile theme (only available in the Professional version for now).

Mobile alerts can be setup in the Webmin System and Server status module. Click on “Scheduled Monitoring”, and at the bottom there is an option labeled “Send SMS to” where you can fill in your carrier and number. This will use the SMTP to SMS gateway that almost all major carriers provide to send you a message–for many phones and plans it is free, though some are faster than others at sending it through (my T-Mobile Sidekick, Jamie’s Sprint Treo, and a friend’s Blackberry all get it in less than a minute).

You also have to enable scheduled monitoring, of course, but I believe that’s pretty well documented in the Webmin wiki, so I won’t go into detail. You can find those docs here:

Holler if mobile access isn’t working the way you’d expect…your phone might not be recognized by Webmin as a mobile device, or the configuration might not be quite right. You should be able to do nearly everything you can do from a big browser from a mobile device, including creating domains, installing scripts, restarting services, etc.

Hi Joe,

am I right to assume that the mobile notification is US-specific?



Hey Chris,

Maybe but not by design or intent. We’ve included all of the providers SMTP-to-SMS gateways we could find, which includes all of the major carriers, and some small carriers, in the US, and probably a few outside of the US–if yours isn’t listed, let us know, and we’ll try to find out how we can send messages to them.

Would be great to see support for Vodafone Australia and New Zealand for which I have mobiles on both networks.

Alternatively, what about support for a paid gateway such as clickatell which should be able to send sms to any phone on any network. It would provide a lot more coverage and flexibility.

I can’t seem to find an SMTP-to-SMS gateway for Vodafone Australia or New Zealand (I did find Japan and UK, though, so it seems likely that there is such a beast and I’m just not seeing it). I’ll keep looking.

I agree that clickatell (or similar) is probably a good way to do. We’ve also considered setting up our own fee-based service. Depends on how many people are interested. So far, most folks who are really interested in the mobile features are telling us that the current free model is working fine. But we’re open minded.


The current free model works if you are in a country that supports such gateways, but if not then the free model doesn’t work at all :slight_smile:

I believe such notification functions to be of great importance to sysadmins and certainly would not be concerned about paying for such sms credits or the like.

Any one else agree?

Just a quick congrats to Jamie and Joe on this mobile accessibility. I purchased the AT&T Tilt (rebranded HTC TyTN II) running WM6 (which TROMPS all over the iPhone which I purchased first and returned). I immediately loaded up my virtualmin site in Pocket Internet Explorer without even thinking that it would be viewed by a mobile theme automatically. I was very happy to see that all of the options were easily accessible and everything functioned. I even updated some packages via my phone…very slick guys. Another great job!

take this as my vote to include support for clickatel sms gateway


We want to use Bulletin Wireless in New Zealand for our SMS gateway. We already have an account set up with them, and they are able to provide international sms gateway facilities, please advise how we enable this gateway in our Virtualmin Pro.


Mobile access should be automatic--when you login via your phone, it should automatically select the mobile theme (only available in the Professional version for now).

Holler if mobile access isn’t working the way you’d expect… your phone might not be recognized by Webmin as a mobile device, or the configuration might not be quite right.

I was using a Treo, and the theme was fine. Then I switched to a Motorola Q and I only get the Title, nothing more. Login is the same, but the Virtualmin Mobile Theme interface only shows the Title.

The Q is running WM6 CE and it’s a smartphone, not a pocketpc like the Treo. IE seems not to work as well, because some sites I have set up with alternate handheld.css stylesheets which worked fine for the Treo get no CSS styling at all on the Q. Which sucks, but it’s good to know that it sucks so I can fix it for the loads of folks who are running WM6 CE now.

I have several joomla sites set up with pda mambot that creates a stripped down site, and they are working perfectly with the Q… but I really really need Virtualmin on my phone. (Mostly so I can flip people out by setting up their site via my phone.) heheheheh

(Mostly so I can flip people out by setting up their site via my phone.)

You’re not alone. We’ve had a couple of people tell us that this is their killer sales technique. They sit down with the customer in the customer’s office…while chatting with them, they keep looking down at their phone…the customer begins to get a little angry that they aren’t paying them any attention, until they say, “Open your browser and go to”. Customer sees existing, good looking site with company name in place, as the web developer explains, “I’ve also setup email, and that application we just talked about”. BAM! Sale has been made, because while business people love to have meetings, they also understand that a bird in the hand is worth two in the bush–the developer in this case put the bird in their hand and they don’t have to worry about how the website, or email, or databases, or whatever works anymore.

Anyway, what appears in the /var/webmin/miniserv.log when you try to login with this phone? That’ll at least let us know whether it is correctly switching to mobile mode for your phone.

miniserv.log says: - root [13/May/2008:17:39:34 -0400] "GET / HTTP/1.1" 200 1680 - root [13/May/2008:17:50:18 -0400] "GET / HTTP/1.1" 200 1680

I also added a bunch of browser agents, thinking that might solve it, but no change:

Mozilla/4/0, Elaine/3.0, iPhone, Palm, EudoraWeb, Blazer, AvantGo, Windows CE, Cellphone, Small, MMEF20, Danger, hiptop, Proxinet, ProxiNet, Newt, PalmOS, NetFront, SHARP-TQ-GX10, SonyEricsson, SymbianOS, UP.Browser, UP.Link, TS21i-10, MOT-V, portalmmm, DoCoMo, Opera Mini, Palm, Handspring, Nokia, Kyocera, Samsung, Motorola, Mot, Smartphone, Blackberry, WAP, SonyEricsson, PlayStation Portable, LG, MMP,OPWV, Symbian, EPOC

Heheh…Oops. I guess that doesn’t give us anything interesting.

Looks like we just need to detect “Windows CE” and “4.01”…though it sounds like “Smartphone; 176x220” will also appear in the user agent string. We probably need to see the exact and full user agent. I’m pretty sure we already do consider anything on Windows CE to be a mobile device…so it’s weird that it’s not working.

Tell you what, just browse this link with your phone:

And send me the IP address and I’ll grep out the user agent. I have combined logging enabled on that site, so I can see the user agent.

done. sent to sales@ and joe@


Awesome. Got it, and have asked Jamie to include the fix.

I’ll also note that you can also use the address m.domain.tld (where domain is one of your virtual servers) to force Webmin into mobile mode. (This won’t work for virtual servers older than maybe a year or so, or if you have custom BIND templates that don’t include an m record, unless you make the m record manually.)

Thanks, seems to be working now.

It’s actually only somewhat working…

I changed to another theme (Stress Free) for mobile to see if it would show up, and it did indeed.

So, I switched back to Webmin Mobile, and it was hit-or-miss… mainly miss. The first time I tried it, it seemed to be working fine, but maybe that was because the pages were cached for the other theme? But it did look like VM Mobile theme, and it did show the proper VM Mobile index page.

However, when I refreshed and went again to the index via https://m.domain.tld:port##, all I get is the Title of the page, and no content.

Seems to be maybe a network connection issue at this point? I dunno…try hitting your system on the "m" address from a regular browser on a landline connection. See if it behaves as expected.