Missing virtualmin-release-latest.noarch.rpm File

Good Morning / Evening!!

Just wanted to say agin how much I enjoy your software, and can’t wait to see some new features.

I have just recently tried switching to Ubuntu base from Fedora Core, but had problems that I just didn’t want to work around.

Going back to Fedora and after getting all the updates I proceed to download the install.sh and reinstall Virtualmin Pro…which I I love to death.

The Output is below. I have read thru the forums and found another instance of the same error, and there was speculation that the username:password string might have been missing…but I have now found that the file ‘virtualmin-release-latest.noarch.rpm’ is in fact missing from the Fedora/6/x86_64 directory…I see that in more recent posts that you have been house cleaning the repos, and I was wondering if and when the virtualmin-release-latest.noarch.rpm file might be updated and put back within the repo…is this for pre-release for Fedora 7 ??

Please let me know.

Bruno Out

Checking for curl or wget…found /usr/bin/curl -s -O
Checking for perl…found /usr/bin/perl
Loading log4sh logging library…
INFO - Started installation log in virtualmin-install.log
INFO - Checking for fully qualified hostname…
INFO - Hostname OK: fully qualified as ns1.the-arachnid.net
INFO - Installing serial number and license key into /etc/virtualmin-license
INFO - Loading OS selection library…
INFO - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded.
INFO - Loading OS list…
INFO - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded.
INFO - Operating system name: Fedora Core Linux
INFO - Operating system version: Fedora 6
INFO - Installing virtualmin-release package for Fedora Core Linux Fedora 6…
INFO - Disabling SELinux during installation…
/usr/sbin/setenforce: SELinux is disabled
INFO - setenforce 0 failed: 1
INFO - Download of http://<Omitted For security>@software.virtualmin.com/fedora/6/x86_64/virtualmin-release-latest.noarch.rpm Succeeded.
error: open of <!DOCTYPE failed: No such file or directory
error: open of HTML failed: No such file or directory
error: open of PUBLIC failed: No such file or directory
-//IETF//DTD HTML 2.0//EN>: not an rpm package (or package manifest):

FATAL - Fatal Error Occurred: Installation of virtualmin-release failed: 4
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
error: package virtualmin-release is not installed
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log.

Howdy Freebrew,

Thanks for brining it to my attention. It only effected the x86_64 FC6 repo…I’ve just fixed it.

Yes, F7 is kinda sorta available. It is wholly untested, though. It also doesn’t know to enable or warn you to enable the Everything repository (which is now required). But if you enable Everything, it’ll probably install on F7 without much trouble.