Missing Perl Module?

OS type and version Ubuntu Linux 20.04.4
Webmin version 1.994
Virtualmin version 7.1-1

Following on from Amazon S3 alternatives for backup I’ve tried to take a look at the Amazon option in VirtualMin > Backup and Restore > Cloud Storage Providers, but receive the error:

Cloud storage provider Amazon S3 cannot be used : The Perl module S3::QueryStringAuthGenerator needed to communicate with Amazon’s S3 service is not installed. Use the Perl Modules page in Webmin to install it.

When I click the Perl Modules link in the error line, I get to an Install Module page which has the following error:

Failed to install module : Module S3::QueryStringAuthGenerator was not found in the CPAN modules list

Perl isn’t something I’ve ever tangled with and I can’t seem to find anything obvious in the UI to manage it, or CPAN. How can I resolve this issue?


PS: I did try Webmin > Tools > Perl Modules and clicking the “From CPAN” radio box and the associated icon that pops up a new window… however searching for “s3” brings up a large list, none of which match S3::QueryStringAuthGenerator



There’s no match for that either - but I’m likely being too literal? Here’s the result list for “s3”, am I right thinking that the first result might be “the whole thing” then?


I assumed you were installing via CLI, but using the GUI the first one would likely be the one.

1 Like

Thanks. Pulled the trigger and that top option maps to

apt-get -y -f install libamazon-s3-perl

Seems to have worked - thank you!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.