Missing or invalid IP address

Hi. Im using the GPL version of Virtualmin (to assess the suitability of the final product) but im having a major problem when I try to add a virtual server to a parent domain (as a non-root user).

Virtualmin simply prints "Failed to create virtual server : Missing or invalid IP address" and hangs.

I initially attributed this to bind, but having checked my config, tried Virtualmin without BIND and even tried PowerDNS to no avail.

Any suggestions would be GREATLY appreciated!

Hey John,

If this is the situation that I think it is, I agree that this error message isn’t as informative as it should be. I believe it has been changed in the Professional version (and will be changed in the GPL version in the next release most likely).

I suspect you are trying to create a domain that requires an IP (virtual FTP requires one, as does SSL), but you’re either not giving it one, or assigning one that already exists on the system (thus Virtualmin assumes it is already being used for something and doesn’t want to step on it).

If this isn’t the case, let me know what input you’re actually giving to Virtualmin that leads to this result. There’s a lot of options…no telling exactly what the problem data is in this case.


I am confronted with the same problem as the original poster, and I can tell you that, at least in my case, the reasoning above does not apply.

The virtualmin install indeed has IP-based virtual hosting enabled, for virtual FTP and SSL servers. But the main virtual server for the user under scrutiny uses the shared IP and doesnt have virtual FTP or SSL enabled. The owner limits prohibit the user from creating SSL servers, using ProFTPd or using virtual IP addresses.

The virtualmin configuration stipulates that SSL website and ProFTPd server configurations are available but not enabled by default.

I have even tried to disable SSL and ProFTPd completely but I was not able to solve this problem (even though we will requires SSL support in the future). I am also using the GPL version currently. Has this issue been sorted in the commercial version of Virtualmin?