milter-greylist: to error state ? not rate limiting mail.

I have two servers setup using virtualmin + ubuntu. the problem i am experiencing is getting the new milter used by virtualmin for ratelimiting to work.

On both my primary server, and secondary, I am experiencing the same issue.

i have tried both reinstallation of the package, and a Purge;

i have upped sendmail to log level 11, and this was the output i found in /var/log/mail.log

Dec 17 18:36:31 rwgu1 sendmail[27493]: rBHNaVnN027493: Milter (dkim-filter): init success to negotiate Dec 17 18:36:31 rwgu1 sendmail[27493]: rBHNaVnN027493: Milter (ratelimit-filter): init success to negotiate Dec 17 18:36:31 rwgu1 sendmail[27493]: rBHNaVnN027493: Milter (ratelimit-filter): to error state Dec 17 18:36:31 rwgu1 sendmail[27493]: rBHNaVnN027493: Milter: connect to filters

i searched the forums for both “greylist” and “ratelimit” to see if there was any discussion on this topic. what i found, did not suffice.

the only other sendmail milter i am using is opendkim; i have tested to see if rate limited is working by setting a low interval of emails per hour on both servers, and attempted to send several emails from my smtp client. mail IS getting through, which is NOT the desired effect.

i have added noauth to greylist.conf; i have also attempted to enabled logging by uncommenting the lines mentioned in greylist.conf, but no logging was actually performed…

furthermore, running “milter-greylist -c” says that our configuration file is seemingly healthy, and is just slightly changed from the default. the daemon is running, as user “greylist”, and adding “verbose” to the configuration and performing “service milter-greylist restart” shows that is seems to be loading properly…

can any body please help me debug my issue, or potentially lend me some advice that might help me get this milter working? thank you for taking the time to read my question, any support would be greatly appreciated

i was actually looking into using this milter for its greylist abilities, and thought that the added ratelimiting function was a great idea. very useful.

is it possible to run it in greylisting mode, while also performing late limiting?

this is a side question, and is something i will have to worry about later. until then, as stated, i have purged & reinstalled

Doesn’t work for me either. I haven’t figured it out yet.

here is the bizarre thing;

I decided to give it another go last night, and installed it on two servers (the primary, and the relay). now, its working just fine on the Relay,

  • but simply refuses to work on the primary server!

the only visible difference is that the primary is running dkim milter and spamassasin using procmail… where as the relay server is just running milter-greylist:

i’ve checked configuration, permissions, and tried a purge/re-install several times… but to no avail… even upping sendmail’s logging to a value or 12 or higher produces no valuable information, and the logging feature of milter-greylist is not co-operating either.

therefore, my relay can use this to help deter some spam, which is nice, but i can not actually use it for the rate limiting feature, because all user information is stored on the primary server (the relay just queues incoming and outgoing to loadbalance and failover mail services…)

hopefully somehow we can get this working :frowning:

p.s. i am running sendmail on both servers, and using near stock configuration with little to no changes