Maximum memory allocation

Virtualmin -> Services -> PHP 5 Configuration -> Resource Limits -> Maximum memory allocation

What is default setting for that? I have 428M, its bit high?

That field displays the “memory_limit” value from your php.ini file.

The default likely varies from one distribution to another (and perhaps even between PHP versions)… but yeah, your value may be on the high end :slight_smile: I believe the value on my system is 16M by default.


Its debian lenny. Its not servers php.ini, that has differend value. That displays: /home/myvirtualserver/etc/php5/php.ini


Yeah, there’s a php.ini for each Virtual Server… whenever the domain is setup, that php.ini is generally taken from the system php.ini located in /etc.

However, it’s possible those values were changed after it was copied out.

You can correct that by editing the memory_limit line of /home/myvirtualserver/etc/php5/php.ini, or just tweaking the value that you see in the Virtualmin UI.


This is weird. I only have in one domain that setting in admin panel. Other servers doesnt show that “PHP 5 Configuration” in menu.

Other weird thing is, i have: /etc/php5/apache2/php.ini in debian. But if i open webmin php config, it shows me:

Too much php.ini’s :o