Mass Import from Plesk 9.2.3

OK, my Plesk server is rapidly going down the toilet… how do I mass move 55 domains into virtualmin/webmin??? Certainly, there has to be a cheat sheet to do this easily. I have root privileges on both servers. I need to migrate files, dbs, mail and IPs.

Plesk 9.2.3 is running on Linux (Centos 5.???)

Virtualmin info:

Operating system CentOS Linux 6.2
Webmin version 1.585 Virtualmin version 3.92 Pro
Theme version 8.4 Time on server 15/May/2012 23:12 , Up 102 days, 5 hours, 55 minutes
Kernel and CPU Linux 2.6.32-220.el6.x86_64 on x86_64 CPU load averages 1.04 (1 min) 0.53 (5 mins) 0.19 (15 mins)
Running processes 226 Real memory 15.57 GB total, 1.14 GB used

Virtual memory 17.70 GB total, 0 bytes used

Local disk space 899.46 GB total, 47.73 GB used

Package updates All Virtualmin packages are up to date.
5 updates to system packages are available. Use the Virtualmin Package Updates module to install them selectively.

How about the following (have never tried it though)

There is also a menu called “add server -> migrate virtual server”:

This page allows you to create a new virtual server by migrating a backup file created by a competitor’s product. The configuration for all supported features will be extracted from the backup, and converted for use by Virtualmin. All contents of the domain’s directory will be copied into the home directory of the new user.

It looks like I have to do them one at a time then. That’s OK, I only have 55. However, I am trying to scp files over and am getting an error…

bash: scp: command not found

this happens when I run this from my laptop in the Downloads directory:

scp -P 1222 05162012_netdocscuba.com_info_120510004.xml.tgz pjmu@

I am using a non-standard port (obviously)

Just so I am on target here…

  1. Back up the domain on Plesk server
  2. Transfer the backup to my laptop
  3. Transfer the back up to Virtualmin server
  4. Run the script in Virtualmin

Will this back dbs as well?

Yup, so long as the Plesk backup contains your database (which it should), Virtualmin will be able to import it.

Also, note that some (but not all) migrations can be done in batch – by placing multiple backup files into a single directory, and then pointing Virtualmin to your directory of Plesk backups.

That doesn’t always work, as sometimes Virtualmin needs more information about each one – but it may be worth a shot :slight_smile:


Cool… any idea on why scp is not working so I can upload the files to virtualmin?

any idea on why scp is not working so I can upload the files to virtualmin

Well, you’re getting a “command not found error”, so it’s likely you just need to install it.

Which distro is it that you’re running that command on?


centos 6.2

I’ve never heard of SCP not being a part of any Linux installation.

What is the output of these two commands:

ls -l /usr/bin/scp rpm -qa | grep openssh-clients

Yeah, I solved the scp issue with a yum install of openssh-client. Apparently, this is normal for Centos 6.2. Thanks for the time and input though.

I am waiting for some new IP addresses to be assigned so I can start moving these servers over. I’ll let you know how it turns out.