Manage domain and emails from Virtualmin for base nameserver domain

Hello everyones!

I successfully installed and configured virtualmin and managing my domains with Bind with webmin correctly.

I own 2 domains currently

Problem is as is base domain where ns1 is set, it don’t appear as a virtual server.
And I can’t find out :

  • Where to set additional email addresses for root or nox users.
  • Manage domain with virtual server features and got on virtual server list

I can manage domain from webmin -> bind configuration currently, which is good but can’t create new email adresses or aliases for this domain anyway.

Any explanations is possible please ?


Did you install Virtualmin with Webmin or just Webmin alone?

Virtualmin with webmin.

Problem is as is base domain where ns1 is set, it don’t appear as a virtual server.

Just to be sure what is your problem, you are saying that domain doesnt appear in Virtualmin under virtual servers but you can see it from various Webmin modules like named, mysql, etc.?

Right. That base domain is used for nameserver and primary website located at /var/www/html (debian used on this server).
I can’t list too other email adresses like or and manage it from webmin, or creates new.

Did you add a virtual host named You need to have a virtual host to make the email work. What the primary domain do is an anchor for the nameservers if you are running your own DNS.

I tried to create a virtual server with base domain and virtualmin answer domain already exist (as it is already set as nameserver in bind configuration) and don’t permit to create it.

The only option to manage base domain to be a virtual server is using virtualmin link “Import existing domain as a virtual server” but I’m afraid using this breaks something as it will create another bind zone file.

Well, maybe everything are not clear with me as I’m not much familiar with bind and domains in general.

How did you add that domain if you didnt use Virtualmin? Did you manually edit files to add domain? This could explain your problem because adding name servers would not prevent you to later add the domain. Just to be sure, did you check under Vmin - List Virtual Servers if you have

Bind is a beast in itself, it is hard to learn and hard to figure out until you gain an intermediate knowledge of it. There are a lot of variable things that can happen which makes bind troubleshooting hard. is not listed, and yes, I initially set that first domain by manually editing it following my registrar documentation.

I think it could be good to try the import of domain and check what to repare after the operation ?

Or you could delete all the current records of that domain and then use Virtualmin. In this way you are sure Virtualmin will do all needed task to properly setup this domain.

Including nameserver records ?

TTL 10800
@ IN SOA (
600 )


and using “Create a new Virtual Server” link.

Or keep existing zone file and using “Import …” link ?

First make a backup of /etc, /var and /home (at least on centos, it could be different on other OS) after that you can test what method is better. But if you just add the domain Virtualmin should setup everything, including DNS.

Hello again,

I did the Import feature and works now, difference now is I have some menu to manage some services for that domain, including possibility to manage new mails and aliases. Virtualmin / Webmin kept original dns zone file while the import operation and minimal services are actually set :

View image

I’ll try next to activate some more services step by step like virtual web server (importing apache existing configuration), anti-spam filter, etc…

Just for you to know.


Great to hear you manage to sort at least one part of the problem. Hope it will go well for the rest.

blur out the username, people can brute force your server knowing that the user name /account on your image exist.