Mails are quiet slow to come and recieve to recipients

OS type and version Ubuntu 22.04
Webmin version 2.111
Virtualmin version 7.10.0 Pro
Related packages Mail Issue

Have you enabled greylisting? If so, there will be a delay on first mail from any new sender, and how long that delay is is up to the sending mail server. It usually about five minutes, but could be shorter or longer.

hi joe, greylisting is off yeah.

Umm dns propagated , set up done created user account as email. dkim spf dmarc enabled. google shows pass on all as no spam.

Unsure why delays on other servers or comany personal servers. May be i missed something?

You’ll need to look at the mail log. Or, more likely the journal. Probably journalctl -fu postfix and then send a mail and watch what happens in the log related to the email.

Good idea Joe,

Let me try and see


Ok i tried.
Its funny, i mailed one mail with four recipients. all four different servers
out of which one was local server same domain , and gmail account

mail logs shows its sent to that and i recieved. but rest two not showing in mail logs yet.

If they don’t show up in the log, they haven’t reached the server. Postfix starts talking about it the moment a remote server tries to send something to it.

So, the delay is either DNS or something out of your control on the sending server(s).

hi team, yeah mail is fine now.
but only issue is outlook from external internet does nt connect to mail server

i am using cloudfare dns system, and nameserver as well.

DNS on virtualmin is disabled.

SSl for is created via letsencrypt.

from external machines only outlook is an issue. roundcube is fine, pings as well. ports forwaded via pfsense.

unsure why externally outlook says cannot connect to mail server. even with ipaddress

whats weird is when i use 110 and 25 externally on outlook. it works. if i put 993/995 and 465/587 it says cannot connect. also does not pop out certificate to install automatically may be? unsure

For security reasons, Cloudflare limits the ports it proxies. Cloudflare does not proxy traffic on mail-related ports by default. Cloudflare primarily focuses on web traffic, which usually runs over ports like 80 (HTTP) and 443 (HTTPS).

hi , but i have not used cloudfare proxied records. proxy is disabled on dashboard.

As a Virtualmin Pro user, you need to allow Virtualmin to manage your Cloudflare DNS, to ensures that all necessary DNS records are in added, for instance, for autodiscover to function properly.

but that implies that you are.
So you should be looking to see if you have mail ports open.

ok i have attached cloudfare dns instead of local files in dns options .

now even ping to domains externally says not found.

is it normal? cannot find mail server

or its part of propagation? after that can i redo lets encrypt? and will it work?


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.