Mailman: Bug in Mailman version 2.1.11


I’m going through the process of transferring over from plesk to web/virtualmin. One of the sticking points that I have is getting mailman up and running.

I installed virtualmin via the which went fine. I’ve created a few virtual servers and that all seems correct.

When I select my virtual server, select mailing lists from the left, I have the interface for the mailing list creation. I can create a mailing list fine. However, when I go to manage this mailing list, I get the: Bug in Mailman version 2.1.11 error.

Looking in /var/lib/mailman I do see the list I created and it has the root:gnats ownership.

Secondly, I tried moving a bunch of my current mailing lists over to the virtualmin machine. I followed these instructions:

When I look at my lists under webmin, they all appear, however, they are not associated with any domain. Clicking on the mange button causes the same error as above?

Sorry if this is a duplicate post. I’ve been looking around for an answer for this for some time, but haven’t found anything that makes sense yet.



Is that all you see in the error message? I would hope it would give us more to go on. You might also check the relevant Apache logs (probably error.log).

That was the error I got in webmin. Here’s the log from /var/log/mailman/error:

Apr 23 20:45:45 2009 admin(9405): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
admin(9405): [----- Mailman Version: 2.1.11 -----]
admin(9405): [----- Traceback ------]
admin(9405): Traceback (most recent call last):
admin(9405): File “/var/lib/mailman/scripts/driver”, line 110, in run_main
admin(9405): main()
admin(9405): File “/usr/lib/mailman/Mailman/Cgi/”, line 71, in main
admin(9405): mlist = MailList.MailList(listname, lock=0)
admin(9405): File “/usr/lib/mailman/Mailman/”, line 130, in init
admin(9405): self.Load()
admin(9405): File “/usr/lib/mailman/Mailman/”, line 638, in Load
admin(9405): dict, e = self.__load(file)
admin(9405): File “/usr/lib/mailman/Mailman/”, line 604, in __load
admin(9405): fp = open(dbfile)
admin(9405): IOError: [Errno 13] Permission denied: ‘/var/lib/mailman/lists/bsb-collective/config.pck’
admin(9405): [----- Python Information -----]
admin(9405): sys.version = 2.5.2 (r252:60911, Jan 4 2009, 17:40:26)
[GCC 4.3.2]
admin(9405): sys.executable = /usr/bin/python
admin(9405): sys.prefix = /usr
admin(9405): sys.exec_prefix = /usr
admin(9405): sys.path = /usr
admin(9405): sys.platform = linux2
admin(9405): [----- Environment Variables -----]
admin(9405): DOCUMENT_REALROOT: /usr/share/webmin
admin(9405): HTTP_REFERER:
admin(9405): SERVER_SOFTWARE: MiniServ/0.01
admin(9405): SCRIPT_NAME: /virtualmin-mailman/admin.cgi
admin(9405): REQUEST_METHOD: GET
admin(9405): LOGNAME: www-data
admin(9405): USER: www-data
admin(9405): SERVER_PROTOCOL: HTTP/1.0
admin(9405): QUERY_STRING:
admin(9405): HOME: /var/www
admin(9405): PATH_REALTRANSLATED: /usr/share/webmin/bsb-collective
admin(9405): SERVER_REALROOT: /usr/share/webmin
admin(9405): HTTP_ACCEPT_CHARSET: ISO-8859-1,utf-8;q=0.7,;q=0.7
admin(9405): BASE_REMOTE_USER:
admin(9405): SHELL: /bin/sh
admin(9405): HTTP_CONNECTION: keep-alive
admin(9405): HTTP_COOKIE: testing=1
admin(9405): SERVER_NAME:
admin(9405): REMOTE_ADDR:
admin(9405): SHLVL: 2
admin(9405): HTTP_KEEP_ALIVE: 300
admin(9405): SERVER_ROOT: /usr/share/webmin
admin(9405): REMOTE_USER: root
admin(9405): SERVER_PORT: 10000
admin(9405): WEBMIN_VAR: /var/webmin
admin(9405): DOCUMENT_ROOT: /usr/share/webmin
admin(9405): PYTHONPATH: /var/lib/mailman
admin(9405): SCRIPT_FILENAME: /usr/share/webmin/virtualmin-mailman/admin.cgi
admin(9405): SERVER_ADMIN:
admin(9405): HTTP_USER_AGENT: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv: Gecko/2009032608 Firefox/3.0.8
admin(9405): HTTP_HOST:
admin(9405): HTTPS: ON
admin(9405): _: /var/lib/mailman/cgi-bin/admin
admin(9405): REQUEST_URI: /virtualmin-mailman/admin.cgi/bsb-collective
admin(9405): HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,
admin(9405): PATH_TRANSLATED: /usr/share/webmin/bsb-collective
admin(9405): GATEWAY_INTERFACE: CGI/1.1
admin(9405): WEBMIN_CONFIG: /etc/webmin
admin(9405): HTTP_ACCEPT_LANGUAGE: en-us,en;q=0.5
admin(9405): PWD: /usr/share/webmin/virtualmin-mailman/
admin(9405): MINISERV_CONFIG: /etc/webmin/miniserv.conf
admin(9405): MAIL: /var/mail/www-data
admin(9405): REMOTE_HOST:
admin(9405): HTTP_ACCEPT_ENCODING: gzip,deflate
admin(9405): PATH_INFO: /bsb-collective

The Permission denied: ‘/var/lib/mailman/lists/bsb-collective/config.pck’

Is: -rw-rw---- 1 root gnats 3730 Apr 23 20:35 /var/lib/mailman/lists/bsb-collective/config.pck

Should that be something else?