Mail working in Thunderbird, but not in Outlook

Hi Folks,

Never needed any help, but now I’m a bit stuck. I’ve setup everything correctly, meaning that everything works, except retrieving e-mail in Outlook 365 client. When I use Thunderbird, everything works out of the box. I’m using the ports 993 and 587 for SMTP. I also compared the settings between clients, and everything looks the same.

I only get a global errer message which says something like: “Something went wrong” I translated this error from the Dutch (NL) language which says: “Er is iets misgegaan”.

Anyone who has an idea where to look?
Thank you very much in advance for thinking with me!

CentOS Linux 7.9.2009
Linux 3.10.0-1160.45.1.el7.x86_64
Webmin: v1.982
Virtualmin: v6.17

So the good thing is that your server is OK and setup correctly - as it works, tested with your Thunderbird. Outlook can be funny about things and may need manually setup with imap/pop3 settings under advance/details. Its a matter of troubleshooting down to the exact issue, which can be long winded and time consuming.

  • Does Outlook accept the SSL certificate?
  • Can Outlook connect to other accounts?
  • Any shields/ antivirus working with Outlook?
  • Is your Outlook 365 private or work? if the latter, they may block additional account setups.

The client has very little useful information. Check the maillog for clues.

@Hielke
New Server / VPS?

If so why then Centos 7x? ( i think is asking for troublesome future while old stuff)

IF work account then also often not allowed by "domain controller and ADDS (Active Directory Domain Services) "

*** Does Outlook accept the SSL certificate?**
Can you tell me how to check this?
*** Can Outlook connect to other accounts?**
Yes. I have 8 other accounts working in Outlook
*** Any shields/ antivirus working with Outlook?**
Not that I know of
*** Is your Outlook 365 private or work? if the latter, they may block additional account setups.**
Private. But this should be an issue in my opinion, because all other accounts work out of the box

Thank you very much for your time and effort to respond to my question @Whoops !

[UPDATE]
I found something strange in the log-files …
Added a screenshot

Could this mean that I have been infected with some kind of ***Ware?
I’m using MCAfee locally, and is up-to-date. Can’t find anything unwanted…

Anyone?

Check what your external IP address is from where you are connecting. If the above is you, you are using wrong credentials. Ensure your username is correct. It may not be user@domain.com but user.something depending on what your server setup is. Note that your webmail.domain.com may accept user@domain.com but Outlook wont. As said above Outlook may require you to put in the details manually, and not use the account wizard setup which normally wont work. I would also temporarily switch mcafee off for a few minutes to test connection. Very often the latter can block auto. At least for troubleshooting purposes its good to test.

That’s it right there. The Outlook auto config has always been dicey. I bet if he checks it it’s all kinds of messed up.

Solved it folks!
Tried everything you guys / gals suggested, but that didn’t do the trick unfortunately :thinking:
This doesn’t mean I’m not happy with your help, actual the opposite! I’m really glad there are people like you.

I don’t think you would guess the solution, because I can’t find a reason WHY it was the solution.
As I said I was using Thunderbird as an alternative and was curious about the antivirus service provided (ClamAV). This wasn’t enabled at this point, so I digged in deeper, to get it to work. The service couldn’t be enabled through the GUI, so I looked for a manual method in this case. I came by this post:

https://www.transip.eu/knowledgebase/entry/700-installing-clamav-in-centos-almalinux/

Followed the instructions and ClamAV was up & running. Don’t know why I did, but I retried the mail in Outlook, and it worked immediately :slight_smile: Totally flabbergasted :smiley:

Does Outlook require some security protection maybe? I’m very grateful for all of your help and support and maybe this will help other people with the same problem also

Could be that one or your actions then forced a restart / reload / reboot for one or more services and then some settings activated /set.

Guess…

1 Like

Think that may have been a coincident? ClamAV on server isn’t required for client Outlook to work. As far as I know. Nevertheless, it’s working now which is the main thing :slight_smile:

It’s Outlook. There is no telling what makes it work or not work.

ClamAV is definitely unrelated. It never interacts with mail clients in any capacity…literally no way for them to talk to each other. Some other change you made along the way, or just restarting services, I guess, did.

Mail clients talk to Postfix for sending and Dovecot for receiving (and neither of those talk directly to ClamAV, either).