Mail system blues due to blacklisted IP addresses

Why is the mailing system so complicated?.. I’ve been trying to connect to a CRM and nothing seems to work. Each server, and sub server allows it’s own emails, and the mail configurations that get created do not work… It’s there a special way to connect to an Outgoing Mail Server?.. TY

sorry, not really sure of your question.

is it a mail setup question, or is it related to incoming and outgoing mail server settings ? or related to SSL certs ?

I am trying to set up the Mail Server Settings (SMTP)
in VTiger CRM. It normally uses,, or, or I set up a server in Virtualmin, ex. I also set up a user, ex. Then while in Edit Users, I clicked on Show Email Client Settings, and tried to configure VTiger with the settings. But, unfortunately nothing seems to work. I’m going on two days on something, that at best, takes 35 sec to configure…

Even trying to use email with Round Cube, it does not send or receive…

does your mail settings work by testing with ?

Just tried it and it works.

using the SMTP test function ?

not sure then.
I’ve been digging around mail server settings over the last week to try and resolve some issues (realted to outlook and btinternet not accepting emails)
and trying with php mail and mime

is your domain th emain server for teh domain, do you have SSL cert set up ?

Yes, main domain on a server. I use a separate domain for the hostname. Both the domain and the sub have SSL installed. This is mind boggling…Such a great control panel. I’ve never had any configuration issues with Cpanel, and CWP…

mail is usually pretty easy with virtualmin, especially if mxtoolbox tests good

are you able to send privately some more information on the domain ?

Ty I am not sure i completely understand what you are trying to do…

Are you saying that you are routing through an external mail service (like mail chimp as an example), or are you simply trying to setup email for domains on your server (virtualmin virtual servers) and connect them with a desktop pc app like outlook?

Out of the box, there is nothing that you need to do on a fresh virtualmin install to get email working…you create a vps, install virtualmin, ensure your virtualmin system name server records (ns1/ns2 etc) are accurate and registered, add a new virtual server (domain for hosting website and email), add an SSL cert, ensure dns records are all correct, then it should just work!

Yes, I’m using a mail client through a CRM called VTiger. Through it I can receive and send emails using the emails credentials. All I have to do is connect the incoming email address and the server id to it. I can’t seem to get it to work.

you also said it didn’t work with Round Cube (online webmail) ?

I was able to send a test email and then it stopped.

probably not related but I ran through, reverse DNS can cause issues with sending (but I don’t think this is your issue just now)

SMTP Banner Check Reverse DNS does not match SMTP Banner

Have you tried restarting Dovecot? If it doesn’t restart, there’s probably a problem in dovecot.conf. It wouldn’t show up in the MX toolbox test because Dove actually keeps running and would pass the tests. It just can’t move mail.

As for the complexity, the first time I installed Virtualmin I had so many mail problems that I gave up and reinstalled CentOS, ready to give up on this splendid panel. But then I realized that a lot of my frustration was with my own lack of knowledge about Postfix, having been a long-time Exim user, and anger at myself for not being able to diagnose and fix the problem.

So I gave it another shot, doing everything exactly as I did the first time: and it worked. And other than the recent issues with Dove’s config getting hosed every time LE renews a cert (which Joe assures us is now fixed), it’s been smooth sailing since.

Try restarting Dove and hope that it vomits because if it does, we know where to look next.


thats actually a good point. there imay an issue with the dovecot conf files in some cases ( missing bracket } ?? )

I’ll try that. I like the panel but, I also think it’s very problematic. I’ve deleted and reinstalled this panel about a dozen times and usually for the same SSL reasons, where sometimes Let’s wouldn’t work and I end up getting locked out.

shouldn’t have to reinstall. i’ve used it on quite a few servers and never had to reinstall
you should open a SSH window to log into them then if you amend teh control panel and get locked out you can still get in and restart services

did you try accessing it using the IP:10000

1 Like

Yeah, I finally have a working version but, now this…:slight_smile:

I rebooted Dovecot and nothing. No issues either.