mail/SMTP not working

trying to get mail working

yesterday, using Thunderbird, i could send mail from a user account on the server to the same account on the server (but not to another domain) - today not even that is working

Thunderbird responds with “The message could not be sent because the connection to Outgoing server (SMTP) was lost in the middle of the transaction.”

i cleared /var/log/maillog to troubleshoot, but subsequent tests produces nothing in the log and procmail.log is also empty

OS type and version AlmaLinux 8.9
Virtualmin version 7.9.0

Looks like your mails are being stalled due to port 25 restriction by your VPS provider,

go to Webmin > Servers > Postfix Mail server > Mail Queue to confirm.

there’s a mail in the queue from yesterday - status is connect to[]:25: Connection refused

for today there’s nothing - if i send mail from Thunderbird to the server with from: and to: being server accounts, TB replies with the error i mentioned

as for port 25, i removed it from CSF because i want to use a secure connection, but now i’m looking for where to set the port in web/virtualmin to make sure i changed it and i can’t find it

If your using CSF as a firewall you must have port 25 open there. Can you explain what is ment by a secure connection ?

i don’t remember the secure port numbers, but i thought 25 was plain text/insecure

i disabled CSF to test and the result is the same when sending from Thunderbird - The message could not be sent because the connection to Outgoing server (SMTP) was lost in the middle of the transaction.

anyway, i opened 25 TCP in/out and restarted CSF - same deal

and again, both maillog and procmail.log files are empty

Have you checked disk space?

plenty of free space

just got the mail i sent yesterday to myself at the myrealbox domain

so i tried sending another from: virtualmin user to the same user and same error from Thunderbird

Have you restarted the postfix/dovecot? Server if possible? No output to the logs is worrisome.

Probably nothing but do you have /var/log/mail.warn and mail.err?

If you don’t have port 25 you don’t have a mail server. You’ll need a relay, or to host mail elsewhere.

@ID10T - i restarted the server earlier and both dovecot and postfix now - problem remains; Thunderbird The message could not be sent because the connection to Outgoing server (SMTP) was lost in the middle of the transaction.

@Joe - 25 is open

sorry, forgot to answer that - negative on both

Those are Debian-isms. Those files will never exist on a RHEL-based system.

You will either have a maillog or entries in the journal for each of the mail-related services. You will never have the same logs a Debian or Ubuntu system has. (Unless you explicitly configure the services to do so.)

My system will drop all sorts of connections EXCEPT this line comes first:
smtpd_relay_restrictions = permit_mynetworks permit_sasl_authenticated defer_unauth_destination

It sounds like what you are experiencing EXCEPT you have no logging.

Restart Postfix to refresh journal. Then.
systemctl status postfix

Also found this.

i deleted /var/log/maillog, restarted rsyslog and postfix - they start normally, however a new maillog is not created

if i check the status of postfix i see activity (connections that should log), but nothing is logged

the debug link you offered provides info i don’t really comprehend, so i reinstalled postfix, enabled it, started it, and instantly there’s a 1.9 MB maillog file in which i’m seeing several lines like…

Jan 15 11:40:02 host postfix/smtpd[10276]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory

if i send mail to the server using my personal mail address to my account on the server, the server accepts the mail but i never receive them

if i send using my server account to: my server account, Thunderbird says…

The message could not be sent because connecting to Outgoing server (SMTP) failed. The server may be unavailable or is refusing SMTP connections. Please verify that your Outgoing server (SMTP) settings are correct and try again

in both cases there is nothing in the mail queue and nothing is logged

Hmm… Virtualmin sets up Postfix so deleting and reinstalling might be a problem. I’ll leave that to others to determine. You might try running Re-check configuration and see if it completes.

Oh no. That wasn’t a great idea.

yeah, i kind of assumed that when i did it, but i’m at the point where i’m ready nuke the whole thing so i didn’t really care

One thing that wasn’t clear to me is if this particular install ever worked or if this was a recent problem.

i’m sure mail would have worked initially, but i disabled postfix at first because i didn’t need it - what happened since then, i don’t know

1 Like