mail return address now:

Strange, yesterday everything seemed fine. Today I get 2 problems:

Mail to any domain bounces with "User unknown in virtual alias table"

postconf -n

[code:1]alias_database = hash:/etc/aliases
alias_maps = hash:/etc/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
inet_interfaces = all
mail_owner = postfix
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, localhost,
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sender_bcc_maps = hash:/etc/postfix/bcc
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated rejec t_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual[/code:1]

Next strange issue:

Sending from webmail works. But mail arrives with sender: instead of

there seem to be some issues too with users and groups. Maybe something happened while I changed one group from to domain, as 2 other domains are that way and worked fine - well, before.

Problem solved.

I noticed that new mailboxes show the correct format when sending. To any newly created mailbox I could also send to with no bounce.

I just deleted and re-created all mailboxes with errors.