Mail not being delivered: Reverse DNS is not a valid Hostname

I am having issues with my shopping carts and my autoresponder emails getting sent into Spam or not being delivered properly. My OS is Ubuntu 14.04 Postfix 2.11.0 and most of the software is up to date. I am using BIND and there are several Domains hosted. This is the last major issue I have from my initial setup.
Any help would be appreciated. I believe that the issue is related to Reverse DNS as MXToolbox reports :

Reverse DNS is not a valid Hostname

When I run hostname the system returns

When I run hostname -f it also returns

What did you set as rDNS?

Either way you have few more problems than just rDNS: is set with my VPS Hosting Company.

Thanks for th info on I can fix a lot of these. It is kind of funny though everything on the server is working well and has for a few months now. The biggest issue I have is the fact that my email is not getting through to several of the larger email suppliers (although some are).


Reverse DNS is something setup by your provider though.

To set the reverse DNS for your server, you can contact their provider, and let them know what you’d like that to be.


I do have it set at the by the provider. They actually give me control through the VPS hosting control panel.

Right not it is set to

It does look like the issue is happening primarily with PHP Mailer. I use an autoresponder on a couple of sites and on the subscription software it sends a confirmation email via PHP Mailer.

While is ok to use domain as rDNS i would like to suggest to go with subdomain, something like hostname.domain.tld while “hostname” can actually be whatever you want. Some people use hostname, some other random letters/numbers, i’m using cartoon names. For email test go here and send email to After that wait few minutes and see what you get back.

I am having a problem where the sender URL for mail from a subdomain is set to “sendername@host1.localdomain” instead of “

I don’t know where to change this configuration?

I have worked around (?) this problem by editing the local php configuration file by adding …

…to the SMTP properties.